1 С8.1 Как умножить поля в таблице документа

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 22 янв 2008.

  1. Гость

    Народ как в 8.1 в полях таблицы документа осуществить умножение(/,+,-) , у меня ни хера не получается,
    так как я в ней ещё лох. Заранее спасиба. :D
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Опиши ситуацию более подробно, ибо к тому что ты написал есть масса вариантов.
    А вообще почитай справку по ТабличномуДокументу или ТаблицеЗначений.
     
  3. Гость

    Ладно, создаем документ, создаем таблицу в документе, создаем реквизиты таблицы документа, Например: Реквизит1, Реквизит2, Реквизит3. Далее создаем основную форму документа где размещаем таблицу с её рекизитами(Реквизит1, Реквизит2, Реквизит3). тоесть стольбцы Реквизит1, Реквизит2, Реквизит3. вопрос как мне перемножить реквизиты Реквизит1, Реквизит2, чтобы найти Реквизит3. в 7.7 пишеш процедуру ...
    реквизит3=реквизит1*реквизит2;
    конецпроцедуры
    и вставляешь наименование этой процедуры в свойство этих полей(Реквизит1, Реквизит2, Реквизит3) и она работает. такой вариант в 8.1 не работает. или я чегото не догоняю. Хелп плиз. Спасибо.
     
  4. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    ну можно попробовать приблизительно так:

    Для каждого СтрокаТД из ТабличныйДокумент Цикл
    СтрокаТД.Реквизит3 = СтрокаТД.Реквизит1 * СтрокаТД.Реквизит2;
    КонецЦикла;

    Только сделай табличную часть, а уже в ней реквизиты

    Или можно даже попроще.
    ТабличныйДокумент.Реквизит3 = ТабличныйДокумент.Реквизит1 * ТабличныйДокумент.Реквизит2;
     
  5. Гость

    Спасибо :)
     
  6. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Не за что. помогло?
     
  7. Гость

    Ни хрена не работает - Реквизит3 неопределен - пишет

    хоят : табличные части
    -таблица
    -реквизит1
    -реквизит2
    -реквизит3
    вот в таком паряде есть, создал кнопку, процедуру, и в ней написал выше перечисленную строку
    ТабличныйДокумент.Реквизит3 = ТабличныйДокумент.Реквизит1 * ТабличныйДокумент.Реквизит2;
    загружаю ввожу данные пишет -------------- поле объекта не обнаруженно(реквизит3).
     
  8. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Реквизит1,2 и 3 - это табличная часть или реквизит табличной части?
     
  9. Гость

    Реквизит таблицы в табличной части документа, тоесть в 2-х словах как представил выше:
    ТАБЛИЧНЫЕ ЧАСТИ - ТАБЛИЦА - РЕКВИЗИТ1,2,3
     
  10. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    А попробуй в процедуру впехнуть целиком цыкл:

    Для каждого СтрокаТД из ТабличныйДокумент Цикл
    СтрокаТД.Реквизит3 = СтрокаТД.Реквизит1 * СтрокаТД.Реквизит2;
    КонецЦикла;
     
  11. Гость

    Всё спасибо KIR разобрался вот че надо было чтоб заработала

    Для каждого СтрокаТД из Таблица Цикл
    СтрокаТД.сумма = СтрокаТД.цена * СтрокаТД.количество;
    КонецЦикла;



    ну напряг конкретный был или с не привычки наверно.
    Спасиба.
     
Загрузка...

Поделиться этой страницей