1c 8 элемент формы поле календаря

Тема в разделе "1C и всё что с ней связано", создана пользователем KarandashTM, 29 апр 2010.

  1. KarandashTM

    KarandashTM Гость

    Здравствуйте.
    Мне необходимо обратится к каждой дате календаря, причем не просто получить значение даты, а манипулировать конкретным числом элемента формы. Например, изменить цвет текста некоторых дат. Как это сделать?
     
  2. Buster

    Buster Гость

    Код ( (Unknown Language)):
    Процедура ПолеКалендаря1ПриВыводеПериода(Элемент, ОформлениеПериода)
    Для каждого ОфПериода из ОформлениеПериода.Даты цикл
    Если ОФПериода.Дата = '20100502' тогда
    ОФПериода.ЦветТекста = WebЦвета.Зеленый;
    ИначеЕсли ОФПериода.Дата = '20100504' тогда
    ОФПериода.ЦветТекста = WebЦвета.Синий;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    ПриВыводеПериода - метод объекта ПолеКалендаря
    Обращайся :)
     
Загрузка...

Поделиться этой страницей