1c V7.7 Rom-mail: Отправленное письмо возвращается с ошибкой.

Тема в разделе "1C и всё что с ней связано", создана пользователем gfn, 1 дек 2008.

  1. gfn

    gfn Гость

    Доброго времени суток.
    Пытаюсь сделать отправку эл. почты из 1С нажатием одной кнопки: цель данного действа - исключить человеческий фактор.
    Для тестирования кода использовал халявный ящик-получатель на mail.ru, на этот ящик письма, сгенерированные ROM-Mail, приходят без проблем.
    При попытке отправить письмо в ящик на сервере orengpb.ru, письмо вернулось с сообщением об ошибке:
    Error=[554 Message is not RFC compliant]

    Вот текст процедуры отправки почты:
    [codebox]
    Процедура ОтправитьПочту_ROM_Mail(п_СписокФайлов)
    Попытка
    Если ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll")=0 Тогда
    Сообщить("Не удалось загрузить ROM-Mail.dll");
    м_флОшибка = 1;
    Возврат;
    КонецЕсли;
    Исключение
    Возврат;
    КонецПопытки;

    Почта = СоздатьОбъект("AddIn.AddInMail");
    Почта.СерверОтправки = "192.168.0.7";
    Почта.ПортОтправки = "2025";
    Почта.Логин = "???????@?????-????.com";
    Почта.Пароль = "******";
    Почта.ПоказыватьПредупреждения = 0;
    Почта.АутентификацияПриОтправке = 1;

    Если Почта.Подключиться("Отправка") = 0 Тогда
    Сообщить("Не удалось подключиться к серверу отправки почты.", "!");
    м_флОшибка = 1;
    Возврат;
    КонецЕсли;
    Почта.АдресОтправителя = "???????@?????-????.com";
    Почта.ИмяОтправителя = СокрЛП(Константа.ВГосреестре);
    Почта.АдресПолучателя = рд_АдресЭлПочты;
    Почта.Тема = СокрЛП(Константа.ВГосреестре) + " пополнение карточных счетов";
    Почта.Тело = СокрЛП(Константа.ВГосреестре) + " пополнение карточных счетов";

    СтрСписок = "";
    Для а = 1 По п_СписокФайлов.РазмерСписка() Цикл
    СтрСписок = СтрСписок + п_СписокФайлов.ПолучитьЗначение(а) + ";";
    КонецЦикла;
    Почта.Вложения = Лев(СтрСписок, СтрДлина(СтрСписок) - 1);
    Почта.Кодировка = "windows-1251";
    Почта.НеКодироватьТему = 0;
    Почта.ПодтверждениеДоставки = 0;
    Почта.ПодтверждениеПрочтения = 0;
    Если Почта.Отправить() = 1 Тогда
    Сообщить(" Файлы успешно отправлены");
    Иначе
    м_флОшибка = 1;
    Сообщить(" Не удалось отправить файлы!", "!");
    КонецЕсли;
    Почта.Отключиться();
    КонецПроцедуры[/codebox]

    Возможно ли решить эту проблемму? Заранее благодарен.
    Код (Text):
     
    Код (Text):
     
     
Загрузка...
Похожие Темы - Rom mail Отправленное
  1. Paume
    Ответов:
    6
    Просмотров:
    3.776
  2. Paume
    Ответов:
    4
    Просмотров:
    4.288
  3. gorlanovmax
    Ответов:
    3
    Просмотров:
    8.475
  4. gorlanovmax
    Ответов:
    29
    Просмотров:
    16.298
  5. Ryko
    Ответов:
    0
    Просмотров:
    169

Поделиться этой страницей