1c7. как обходить значения ТЗ

Тема в разделе "1C и всё что с ней связано", создана пользователем KiR, 30 май 2008.

  1. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    В восьмерке есть очень удобный цикл для обхода таблиц значения - для каждого. Подскажите пожалуйстка чем нужно пользоваться в семерке чтобы получить аналогичный результат
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    В семерку нужно пользоваться синтаксис помощником, и описанием встроенного языка.
     
  3. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Ну да. Дурацкая семерка. Геморно обрабатывает тз.
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    //команды со строками
    КонецЦикла
    Фиг догадаешься.
     
  4. Isabela

    Isabela Гость

    Вот так все и сделай, что же тут дурацкого, кроме того, что вместо
    ТЗ.ВыбратьСтрокУ();
    надо
    ТЗ.ВыбратьСтрокИ();
     
  5. LSH

    LSH Гость

    Вот вам еще на вскидку 2 способа обхода в дурацкой семерке (актуальны в ряде случаев):

    Код (Text):
    Для а = 1 По ТаблЗн.КоличествоСтрок() Цикл
    ТаблЗн.ПолучитьСтрокуПоНомеру(а);
    ...
    КонецЦикла;
    Код (Text):
    а = 1;
    Пока а <= ТаблЗн.КоличествоСтрок() Цикл
    ТаблЗн.ПолучитьСтрокуПоНомеру(а);
    а = а+1;
    ...
    КонецЦикла;
     
Загрузка...

Поделиться этой страницей