1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

1c7. как обходить значения ТЗ

Тема в разделе "Базы данных и администрирование", создана пользователем KiR, 30 май 2008.

  1. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    В восьмерке есть очень удобный цикл для обхода таблиц значения - для каждого. Подскажите пожалуйстка чем нужно пользоваться в семерке чтобы получить аналогичный результат
     
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    В семерку нужно пользоваться синтаксис помощником, и описанием встроенного языка.
     
  3. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Ну да. Дурацкая семерка. Геморно обрабатывает тз.
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    //команды со строками
    КонецЦикла
    Фиг догадаешься.
     
  4. Isabela

    Isabela Гость

    Репутация:
    0
    Вот так все и сделай, что же тут дурацкого, кроме того, что вместо
    ТЗ.ВыбратьСтрокУ();
    надо
    ТЗ.ВыбратьСтрокИ();
     
  5. LSH

    LSH Гость

    Репутация:
    0
    Вот вам еще на вскидку 2 способа обхода в дурацкой семерке (актуальны в ряде случаев):

    Код:
    Для а = 1 По ТаблЗн.КоличествоСтрок() Цикл
    ТаблЗн.ПолучитьСтрокуПоНомеру(а);
    ...
    КонецЦикла;
    Код:
    а = 1;
    Пока а <= ТаблЗн.КоличествоСтрок() Цикл
    ТаблЗн.ПолучитьСтрокуПоНомеру(а);
    а = а+1;
    ...
    КонецЦикла;
     
Загрузка...

Поделиться этой страницей