1c7. как обходить значения ТЗ

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#1
В восьмерке есть очень удобный цикл для обхода таблиц значения - для каждого. Подскажите пожалуйстка чем нужно пользоваться в семерке чтобы получить аналогичный результат
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
В семерку нужно пользоваться синтаксис помощником, и описанием встроенного языка.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#3
Ну да. Дурацкая семерка. Геморно обрабатывает тз.
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
//команды со строками
КонецЦикла
Фиг догадаешься.
 
I

Isabela

#4
Вот так все и сделай, что же тут дурацкого, кроме того, что вместо
ТЗ.ВыбратьСтрокУ();
надо
ТЗ.ВыбратьСтрокИ();
 
L
#5
Вот вам еще на вскидку 2 способа обхода в дурацкой семерке (актуальны в ряде случаев):

Код:
Для а = 1 По ТаблЗн.КоличествоСтрок() Цикл
ТаблЗн.ПолучитьСтрокуПоНомеру(а);
...
КонецЦикла;
Код:
а = 1;
Пока а <= ТаблЗн.КоличествоСтрок() Цикл
ТаблЗн.ПолучитьСтрокуПоНомеру(а);
а = а+1;
...
КонецЦикла;