1c77 ТиС9.2 не могу провести документ началом дня

vbs

Well-known member
18.02.2007
1 708
1
#1
При проведении диалог с запросом времени. Пользователь нажимает "в начало дня".
Документ проводится текущим временем.
То же при распроведении и изменении времени документа - опять же проводится текущим временем.
Может, я какие настройки забыл ?
Все птички на закладке "Оперативный учет" в сервисе сняты...
 
T

TimeDontWait

#2
А раннее такое не замечалось ?
в модуле документа ничего нету для изменения времени ?
 

puh14

Well-known member
11.07.2008
1 412
0
#4
Может где-то между записью с запросом времени и проведением дополнительно стоит записать() ?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#5
у мя та же проблема. приходится распроводить документ, менять время на начало дня, а потом уже групповой обработкой проводить все скопом. думаю в глобальный модуль поставить проверку на тип документов с функцией начала для.
 
T

TimeDontWait

#6
Ребята поищите вот эту функцию в модуле:
АвтоВремя
 
T

TimeDontWait

#7
И еще одно: а какой именно документ ? или все ?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#8
у мну Приходный кассовый ордер, остальные нет надобности делать началом дня
 
T

TimeDontWait

#9
Не особо разбираюсь в ТиС, могу ошибаться, но внимание привлекло нечто:

Код:
Процедура ПриОткрытии()
...

//Если документ еще не проведен, тогда 
//проведение делаем только в потоке
Если ( Проведен() = 0 ) Тогда
ПроводитьПослеТА(1,1);
КонецЕсли;
...
Дальше цитирую:
ПроводитьПослеТА(<?>,);
Синтаксис:
ПроводитьПослеТА(<ФлагДляНеПров>,<ФлагДляПров>)
Назначение:
Установить режим проведения документа после ТА. Возвращает текущее значение режима перепроведения документа в зависимости от проведенности.
Параметры:
<ФлагДляНеПров> - режим проведения документа после ТА. Число: -1 (минус единица) - проводить документ всегда задним числом; 0 - при проведении запрашивать режим проведения документа; 1 - проводить документ в реальном потоке времени, т.е. при проведении время документа автоматически устанавливается на время после ТА.
<ФлагДляПров> - режим перепроведения документа после ТА. Числовое выражение: -1 (минус единица) - проводить документ всегда задним числом; 1 - проводить документ в потоке.
 

vbs

Well-known member
18.02.2007
1 708
1
#10
попробовал ПроводитьПослеТА(0,-1); - запрашивать диалог времени и ВСЕГДА проводить задним числом
Вроде, мой случай, но ведь не работает, зараза, олять после ТА ставится :*цензура*you:

Добавлено: Сорри, с флагами напутал.
Лечит
ПроводитьПослеТА(-1,-1);
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#11
Не особо разбираюсь в ТиС, могу ошибаться, но внимание привлекло нечто:

Код:
Процедура ПриОткрытии()
...

//Если документ еще не проведен, тогда 
//проведение делаем только в потоке
Если ( Проведен() = 0 ) Тогда
ПроводитьПослеТА(1,1);
КонецЕсли;
...
Спасибо за мысль! а из какого дока и какого релиза данный кусок кода?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#14
и верно, что-то с первого раза толи не туда глянул, толи не заметил. типа просто нужно флаги поменять и будет счастье?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#15
опять напарываюсь на эти грабли. в заявке покупателя (Тис 964) тоже в процедуре ПриОткрытии есть
Код:
Если ( Проведен() = 0 ) Тогда
    ПроводитьПослеТА(1,1);
КонецЕсли;
толи я неправильно понимаю, толи не отрабатывает эта функция. ведь при проведении документа автоматически должно присваиваться время после ТА, но этого не происходит. в чем может быть косяк?
 

vbs

Well-known member
18.02.2007
1 708
1
#16
Попробуй подергать настройки на закладке "Оперативный учет" в сервисе