1С 7.7 + Веб-камера

gorlanovmax

Well-Known Member
19.06.2008
286
0
#1
Кто-нибудь подключал к 1С веб-камеру?
Типа нажал кнопочку и камера сфотографировала того кто попал в объектив и сохранила фотку
 
J

jcnby

Гость
#2
:) мысль кстати интересная....вот только осталось найти программера который смог бы описать работу самой камеры, а в 1с запустить через приложение и от туда выполнять основные команды
 

gorlanovmax

Well-Known Member
19.06.2008
286
0
#3
да в том-то и дело. где-то в сети я видел процедуру подключения. а сейчас найти не могу((((
 

gorlanovmax

Well-Known Member
19.06.2008
286
0
#4
вот что нашел. народ пишет что работает.

Для 7.7

Код:
Перем oDevice[5];
Device = CreateObject("WIA.DeviceManager");
Количество = Device.DeviceInfos.Count;
Для К=1 По Количество Цикл
Если Device.DeviceInfos(к).Type = 3 Тогда
Попытка
oDevice[к] = Device.DeviceInfos(к).Connect();
Исключение
oDevice[к] = 0;
КонецПопытки;
Иначе
oDevice[к] = 0;
КонецЕсли;
КонецЦикла;

Для К = 1 По Количество Цикл
Если oDevice[к] <> 0 Тогда
Item = oDevice[к].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
Image.SaveFile("D:\aaa.jpg");
КонецЕсли;
КонецЦикла;
Только у меня пишет ошибку:

Device = CreateObject("WIA.DeviceManager");
{Документ.Посетитель.Форма.Модуль(55)}: Неудачная попытка создания объекта (WIA.DeviceManager)
может знает кто, в чем дело?
 
J

jcnby

Гость
#6
какое-то нерациональное применение камеры)