1С 7.7 + Веб-камера

Тема в разделе "1C и всё что с ней связано", создана пользователем gorlanovmax, 7 авг 2008.

  1. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    Кто-нибудь подключал к 1С веб-камеру?
    Типа нажал кнопочку и камера сфотографировала того кто попал в объектив и сохранила фотку
     
  2. jcnby

    jcnby Гость

    :) мысль кстати интересная....вот только осталось найти программера который смог бы описать работу самой камеры, а в 1с запустить через приложение и от туда выполнять основные команды
     
  3. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    да в том-то и дело. где-то в сети я видел процедуру подключения. а сейчас найти не могу((((
     
  4. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    вот что нашел. народ пишет что работает.

    Для 7.7

    Код (Text):
    Перем oDevice[5];
    Device = CreateObject("WIA.DeviceManager");
    Количество = Device.DeviceInfos.Count;
    Для К=1 По Количество Цикл
    Если Device.DeviceInfos(к).Type = 3 Тогда
    Попытка
    oDevice[к] = Device.DeviceInfos(к).Connect();
    Исключение
    oDevice[к] = 0;
    КонецПопытки;
    Иначе
    oDevice[к] = 0;
    КонецЕсли;
    КонецЦикла;

    Для К = 1 По Количество Цикл
    Если oDevice[к] <> 0 Тогда
    Item = oDevice[к].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
    Image = Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
    Image.SaveFile("D:\aaa.jpg");
    КонецЕсли;
    КонецЦикла;
    Только у меня пишет ошибку:

    может знает кто, в чем дело?
     
  5. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    Все, проблема решена. У меня не было вот этой библиотеки.
    http://download.microsoft.com/download/Win...S/WIAAutSDK.zip

    кому нужна, качайте.

    И все отлично работает. Просто сказка. Нажал кнопку - и фото загружено в базу и привязано в клиенту.
     
  6. jcnby

    jcnby Гость

    какое-то нерациональное применение камеры)
     
  7. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    почему нерационально, а что Вы хотели от камеры?
     
Загрузка...

Поделиться этой страницей