1С + Email

  • Автор темы Pro
  • Дата начала
P
#1
Возникла задачка:
1. нужно проверять опр. почтовый ящик
2. при нахождение там новых писем, загружать прикрепленные к этим письмам файлы .xls
3. письма оставлять на почтовом сервере
4. обработка этих файлов

вопрос в следующем, чем, какой компонентой из 1С можно работать с почтой?
 
J

jcnby

#2
а версия 1с? 7.7 али 8.0?
в 8.0 есть непосредственно Почта и ИнтернетПочта ..... с 7.7 нада внешние приложения привлекать

для 8.0

Код:
Профиль = Новый ИнтернетПочтовыйПрофиль;
//адрес STMP-сервера
Профиль.АдресСервераSMTP = "stmp.mail.ru";
//Адрес POP3-сервера
Профиль.АдресСервераPOP3 = "pop.mail.ru";
// порт протокола SMTP
Профиль.ПортSMTP = 25;
Профиль.ПортPOP3 = 110;
//Имя пользователя
Профиль.Пользователь = "ЫТЬ";
Профиль.ПользовательSMTP = "ыгыть";
Профиль.Пароль = "нунах!";
Профиль.ПарольSMTP = "тудаж";
Профиль.ВремяОжидания = 30;

Почта = Новый ИнтернетПочта;
Попытка
Почта.Подключиться(профиль);
Исключение
Сообщить(ОписаниеОшибки());
Возврат;
КонецПопытки;
ТабличноеПолеИнтернетПочта.Очистить();
Сообщения = Почта.Выбрать(Ложь);
Для каждого Сообщение из Сообщения Цикл
СтрокаТП = ТабличноеПолеИнтернетПочта.Добавить();
КомуВходящие = "";
Для каждого Получатель Из Сообщение.Получатели Цикл
КомуВходящие = КомуВходящие + Получатель.Пользователь + " <" + Получатель.Адрес + "> ";
КонецЦикла;
СтрокаТП.Кому = КомуВходящие;
СтрокаТП.ОтКого = Сообщение.Отправитель.Пользователь + " <" + Сообщение.отправитель.Адрес + "> ";
СтрокаТП.Тема = Сообщение.Тема;
ТекстВходящие = "";
Для каждого ТекстСообщения Из Сообщение.Тексты Цикл
ТекстВходящие = ТекстВходящие + ТекстСообщения.Текст;
КонецЦикла;
СтрокаТП.Текст = ТекстВходящие;
СтрокаТП.ДатаОтправления = Сообщение.ДатаОтправления;
Для каждого Вложение из Сообщение.Вложения Цикл
Вложение.Данные.Записать("C:\Mail\"+Вложение.имя);
КонецЦикла;
КонецЦикла;
Почта.Отключиться();
На форму расположить табличное поле "ТабличноеПолеИнтернетПочта"
 
P
#4
платформа 7.7
rom-mail не работает не видет аттачи и лепит их в текст письма...
 

Zab

Well-known member
07.08.2006
583
0
#5
А чем не катит настроить правила в бате? Сохранять атачи на диск, а 1С-иной смотреть эту папку.
 
P
#6
тама нужно что бы работал автомат.... не привлекая народ...