1с и буфер обмена

Тема в разделе "1C и всё что с ней связано", создана пользователем Alexis, 21 сен 2011.

  1. Alexis

    Alexis Member

    Регистрация:
    12 ноя 2010
    Сообщения:
    5
    Симпатии:
    0
    Доброго времени суток!
    Есть одна интересная задача - в обработке для 1С 8.1 надо написать процедуру, которая бы при двойном щелчке по надписи в окне копировало бы текст надписи в буфер обмена. Эта процедура должна работать с минимальными правами. Я попробовал вот это:

    Процедура ВставитьТекстВБуферОбмена(СодержимоеВБуферОбмена) Экспорт
    #Если Клиент Тогда
    Если (ТипЗнч(СодержимоеВБуферОбмена) = Тип("Строка")) И (СокрЛП(СодержимоеВБуферОбмена) <> "") Тогда
    Объект = Новый COMОбъект("htmlfile");
    Объект.ParentWindow.ClipboardData.Setdata("Text", СодержимоеВБуферОбмена);
    КонецЕсли;
    #КонецЕсли
    КонецПроцедуры

    Почему-то эта процедура срабатывает два-три раза, а потом начинает выдавать ошибку. после выхода и повторного входа в обработку проблема исчезает, и снова появляется через несколько срабатываний. Как это исправить?
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Для начала расскажите, что интересного в этой задачке? После - потрудитесь сообщить, какая именно ошибка у вас возникает.
     
  3. Alexis

    Alexis Member

    Регистрация:
    12 ноя 2010
    Сообщения:
    5
    Симпатии:
    0
    Ошибка такая:

    {Форма.Форма(4)}: Метод объекта не обнаружен (Setdata)
    Объект.ParentWindow.ClipboardData.Setdata("Text", Текст);
     
  4. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    А интересного в этой задачке то что можно создать "супер загрузку из ексель". Копируем в буфер обмена таблицу из екселя в 1с получаем ее и делаем разбор полей. На все про все одна кнопка :) Мечта любого пользователя.
     
  5. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    * А не может спустя время буфер закакаться чем-то нетекстовым?
    * А что если его очищать после использования?
     
Загрузка...

Поделиться этой страницей