1С Предприятие 8.1

Тема в разделе "1C и всё что с ней связано", создана пользователем Vazzzo, 16 янв 2008.

  1. Vazzzo

    Vazzzo Гость

    На основе готового запроса надо создать выходную форму - макет. Не получается сделать нумерацию списка..учитывая что в 1с я новичёггг, может мне кто-что может посоветовать, лит-ру какую-нить скинуть. Буду очень признателен. Work_box84@mail.ru


    делаю так:
    Использую мастер отчетов

    на закладке Запрос-----Процедуры------После выполнения запроса прописал:
    РабочиеПеременные.Вставить ("НомерСтроки",1)

    на закладке Запрос-----Процедуры------Вывод в таблицу записи результата прописал:
    ПоляЗаписиЗапроса["НомерСтроки"]=РабочиеПеременные.НомерСтроки;
    РабочиеПеременные.НомерСтроки=РабочиеПеременные.НомерСтроки+1;

    ну и в макете вставляю параметр <НомерСтроки>

    а он мне выводит номера начиная с 3,4,5...
    а нужно 1,2,3,4...
     
  2. Vazzzo

    Vazzzo Гость

    Лана, на эту тему забейте. Сделал с помошью процедуры
    ТекущаяОбласть = Неопределено;
    ТекущийНомер = 1;
    Пока Истина Цикл
    ТекущаяОбласть = ОбъектВывода.НайтиТекст("НомерСтроки", ТекущаяОбласть,, Истина);
    Если ТекущаяОбласть <> Неопределено Тогда
    ТекущаяОбласть.Текст = ТекущийНомер;
    ТекущийНомер = ТекущийНомер + 1;
    Иначе
    Прервать;
    КонецЕсли;
    КонецЦикла;
    вроде работает...
    теперь не могу сделать другое:
     
  3. Vazzzo

    Vazzzo Гость

    Вообщем не получается сделать нумерацию внутри группировок...и перенисти итоги по группировкам в конец списка (относительно каждой группировки) :)
     
  4. Гость

    Народ как в 8.1 в документе умножить(/,+,-) в таблице, у меня ни хера не получается,
    так как я в ней ещё лох
     
  5. Laros

    Laros Гость

    Народ помогите пожалуйста недавно начал изучать сею замечательную программу вроде начал разбираться, патом как это бывает у новичков встретился с проблемой.
    Вопрос в следующим
    -Как создать закладку с именем тоесть пустую закладку с именем без данных самую простую
    -Как создать поиск
    базу то простую создал а с этим ладу дать нимогу
    Я примерно догадываюсь что закладка делается в отчете но подскажите пожалуйста более пападробней
    Заранее спасибо!!!
     
  6. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Очень просто. получаешь строку с таблицы и делаешь с ней все что угодно. Например:
    Для каждого СтрокаТЗ из ТЗ Цикл
    СтрокаТЗ.Сумма = СтрокаТЗ.Число1+СтрокаТЗ.Число2;
    СтрокаТЗ.Произведение = СтрокаТЗ.Число1*СтрокаТЗ.Число2;
    КонецЦикла

    непонятно о чем речь
    закладка это объект на форме - точно так же как и кнопка. погляди повнимательнее при конструировании формы
     
Загрузка...

Поделиться этой страницей