1С:Предприятие в.7. Помогитеееее плизЗ!

  • Автор темы DiLLe
  • Дата начала
Статус
Закрыто для дальнейших ответов.
D

DiLLe

#1
// ********************
//
Процедура ОбработкаПроведения()

//Здесь следует написать алгоритм проведения документа
Док = СоздатьОбъект("Документ.Товары");

// позиционируем документ по номеру

Док.НайтиПоНомеру("1", 0);

Если Док.Выбран() = 1 Тогда

// если документ найден

// открываем выборку строк спецификации документа

Док.ВыбратьСтроки();

// цикл выбора строк спецификации документа

Если Док.КоличествоСтрок() > 0 Тогда

Пока Док.ПолучитьСтроку() = 1 Цикл

Док.УдалитьСтроку();

КонецЦикла;

КонецЕсли;

КонецЕсли;

ТекстДок.Записать("Магазин.txt");



КонецПроцедуры

Почему ругается:
ТекстДок<<?>>.Записать("Магазин.txt");
{Документ.Товары.Модуль Документа(34)}: Переменная не определена (ТекстДок)
 
D

DiLLe

#3
Да не, ты не понял. Я этот язык ваще не знаю, нуб короче...то, что "переменная не определена" мне ни о чем не говорит=))) Мне надо чтобы файл сохранялся в "Магазин.txt", пойми я ваше не шарю, можешь или можете отписать кто нить чо делать там ваще??? Очень срочно надо!!!
 

vbs

Well-known member
18.02.2007
1 708
1
#4
-Доктор, зуб болит.
-У меня прием до шести
-Ну сделайте хоть что-нибудь !
Доктор разворачивается и дает больному в глаз :
- Иди к глазному, он до семи

Простите, если анекдот с бородой, но уж больно он здесь к месту
Мне надо чтобы файл сохранялся в "Магазин.txt", пойми я ваше не шарю, можешь или можете отписать кто нить чо делать там ваще??? Очень срочно надо!!!
А ПТУшная лексика в сочетании с дилетантским запалом выглядит забавно :whoareyou?:
 
D

DiLLe

#5
Огорчил ща. При чем тут ПТУ? Я в колледже учусь, у мя препод по базам данных говно, нихрена не объясняет...вот этот "текст" который в модуле вписывается мы должны были откуда то скопировать, а про ошибки он нас не предупредил что могут быть, а разбираться с ними мы естесвенно сами должны. Ай в ..зду(( хер сдам кароч...Спс.
 

vbs

Well-known member
18.02.2007
1 708
1
#7
И вот такие "выпускники" в дальнейшем будут считаться специалистами в предметной области :whoareyou?:
 

SeverBap

Well-known member
18.09.2007
451
0
#8
Код:
Процедура ОбработкаПроведения()
Док = СоздатьОбъект("Документ.Товары");
ТекстДок = СоздатьОбъект("Текст");
// позиционируем документ по номеру

Док.НайтиПоНомеру("1", 0);

Если Док.Выбран() = 1 Тогда

// если документ найден

// открываем выборку строк спецификации документа

Док.ВыбратьСтроки();

// цикл выбора строк спецификации документа


Пока Док.ПолучитьСтроку() = 1 Цикл
ТекстДок.ДобавитьСтроку(СокрЛП(Док.Товар)+" или мой текст");
Док.УдалитьСтроку();
КонецЦикла;
КонецЕсли; 
ТекстДок.Записать("Магазин.txt");
КонецПроцедуры
Тебе надо было вывести в файл список товаров??????
 

Дайнеко

Well-known member
19.11.2009
951
0
#9
Браво, Bap!

Потрясен Вашим великодушием (аподисменты). Такой красивый модуль и ни слова о ПТУ.
Я позволю подчеркнуть для " DiLLe ", что его проблема в отсутствии строки:

ТекстДок = СоздатьОбъект("Текст");

А может его проблема в чем-то другом?
 

unknown181538

НеГуру
28.12.2008
1 417
0
#10
Браво, Bap!

Потрясен Вашим великодушием (аподисменты). Такой красивый модуль и ни слова о ПТУ.
Я позволю подчеркнуть для " DiLLe ", что его проблема в отсутствии строки:
Ну так мне, как человеку без образования, завидно просто)... злой я...

Я позволю подчеркнуть для " DiLLe ", что его проблема в отсутствии строки:
И в отсутствии представления о понимании слова "переменная"... и умения вежливо спросить... слезная история там...
 

vbs

Well-known member
18.02.2007
1 708
1
#11
1. Согласен. Нет никакого желания помогать человеку, который излагает свою просьбу в хамской форме, да и вообще, не включая голову, сразу ищет халяву
2. Думаю, что нашлось бы немало программистов, которые бы грамотно написали эти пять строчек, но... (см. п.1)
 
Статус
Закрыто для дальнейших ответов.