1С:Предприятие в.7. Помогитеееее плизЗ!

Тема в разделе "1C и всё что с ней связано", создана пользователем DiLLe, 14 мар 2010.

Статус темы:
Закрыта.
  1. DiLLe

    DiLLe Гость

    // ********************
    //
    Процедура ОбработкаПроведения()

    //Здесь следует написать алгоритм проведения документа
    Док = СоздатьОбъект("Документ.Товары");

    // позиционируем документ по номеру

    Док.НайтиПоНомеру("1", 0);

    Если Док.Выбран() = 1 Тогда

    // если документ найден

    // открываем выборку строк спецификации документа

    Док.ВыбратьСтроки();

    // цикл выбора строк спецификации документа

    Если Док.КоличествоСтрок() > 0 Тогда

    Пока Док.ПолучитьСтроку() = 1 Цикл

    Док.УдалитьСтроку();

    КонецЦикла;

    КонецЕсли;

    КонецЕсли;

    ТекстДок.Записать("Магазин.txt");



    КонецПроцедуры

    Почему ругается:
    ТекстДок<<?>>.Записать("Магазин.txt");
    {Документ.Товары.Модуль Документа(34)}: Переменная не определена (ТекстДок)
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    вот поэтому и ругается

    А что хотел сделать-то ?

    А процедура ОбработкаПроведения, в общем-то, понравилась, только никакого проведения в ней обнаружить не удалось -:rolleyes:
     
  3. DiLLe

    DiLLe Гость

    Да не, ты не понял. Я этот язык ваще не знаю, нуб короче...то, что "переменная не определена" мне ни о чем не говорит=))) Мне надо чтобы файл сохранялся в "Магазин.txt", пойми я ваше не шарю, можешь или можете отписать кто нить чо делать там ваще??? Очень срочно надо!!!
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    -Доктор, зуб болит.
    -У меня прием до шести
    -Ну сделайте хоть что-нибудь !
    Доктор разворачивается и дает больному в глаз :
    - Иди к глазному, он до семи

    Простите, если анекдот с бородой, но уж больно он здесь к месту
    А ПТУшная лексика в сочетании с дилетантским запалом выглядит забавно :whoareyou?:
     
  5. DiLLe

    DiLLe Гость

    Огорчил ща. При чем тут ПТУ? Я в колледже учусь, у мя препод по базам данных говно, нихрена не объясняет...вот этот "текст" который в модуле вписывается мы должны были откуда то скопировать, а про ошибки он нас не предупредил что могут быть, а разбираться с ними мы естесвенно сами должны. Ай в ..зду(( хер сдам кароч...Спс.
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    ужос... :*цензура*you:
     
  7. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    И вот такие "выпускники" в дальнейшем будут считаться специалистами в предметной области :whoareyou?:
     
  8. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Код (Text):
    Процедура ОбработкаПроведения()
    Док = СоздатьОбъект("Документ.Товары");
    ТекстДок = СоздатьОбъект("Текст");
    // позиционируем документ по номеру

    Док.НайтиПоНомеру("1", 0);

    Если Док.Выбран() = 1 Тогда

    // если документ найден

    // открываем выборку строк спецификации документа

    Док.ВыбратьСтроки();

    // цикл выбора строк спецификации документа


    Пока Док.ПолучитьСтроку() = 1 Цикл
    ТекстДок.ДобавитьСтроку(СокрЛП(Док.Товар)+" или мой текст");
    Док.УдалитьСтроку();
    КонецЦикла;
    КонецЕсли;
    ТекстДок.Записать("Магазин.txt");
    КонецПроцедуры
    Тебе надо было вывести в файл список товаров??????
     
  9. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Браво, Bap!

    Потрясен Вашим великодушием (аподисменты). Такой красивый модуль и ни слова о ПТУ.
    Я позволю подчеркнуть для " DiLLe ", что его проблема в отсутствии строки:

    ТекстДок = СоздатьОбъект("Текст");

    А может его проблема в чем-то другом?
     
  10. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Ну так мне, как человеку без образования, завидно просто)... злой я...

    И в отсутствии представления о понимании слова "переменная"... и умения вежливо спросить... слезная история там...
     
  11. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    1. Согласен. Нет никакого желания помогать человеку, который излагает свою просьбу в хамской форме, да и вообще, не включая голову, сразу ищет халяву
    2. Думаю, что нашлось бы немало программистов, которые бы грамотно написали эти пять строчек, но... (см. п.1)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей