1с V8 обращение к подчиненному справочнику

Тема в разделе "1C и всё что с ней связано", создана пользователем New2011, 17 июн 2010.

  1. New2011

    New2011 Гость

    v8.1 ЗиК ,8.1.15.14
    Скажите,пожалуйста, как правильно обратиться к подчиненому справочнику и создать в нем элементы. ПодразделенияОрганизаций подчинен спр.Организации.В базе тока одна организация, создаю для этой одной организации ее подразделения:
    Код ( (Unknown Language)):
    СпрПодр = Справочники["ПодразделенияОрганизаций"];
    Организ=СпрОрг.НайтиПоКоду("000000001");
    если Организ.Пустая() тогда
    иначе
    сообщить(Организ);
    КонецЕсли;
    Для i = 2 по ВсегоСтрок цикл
    Значение_X1Y1 = EXCEL_ПолучитьЗначениеЯчейки2 (ТекущаяСтраница, i, 1);
    выборка=СпрПодр.Выбрать(,Организ);//на этом этапе Организ именнно та организация, которая нужна.
    Пока выборка.Следующий()=1 цикл
    НовЭл = СпрПодр.СоздатьЭлемент();
    НовЭл.Наименование=сокрлп(Значение_X1Y1);
    НовЭл.Записать();
    КонецЦикла;
    КонецЦикла;
    После выполнения этого фрагмента,пишет,что "Владелец не задан или задан неверно!" :)
     
  2. has

    has Гость

    Скорей всего тут нада задать владельца

    НовЭл = СпрПодр.СоздатьЭлемент();
    НовЭл.Владелец = Организ;
    НовЭл.Наименование=сокрлп(Значение_X1Y1);
    НовЭл.Записать();
     
  3. New2011

    New2011 Гость

    ларчик так просто открывался,спасибо.
     
  4. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    выборка там вообще не нужна....
     
Загрузка...

Поделиться этой страницей