• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

1с V8 обращение к подчиненному справочнику

  • Автор темы New2011
  • Дата начала
N

New2011

#1
v8.1 ЗиК ,8.1.15.14
Скажите,пожалуйста, как правильно обратиться к подчиненому справочнику и создать в нем элементы. ПодразделенияОрганизаций подчинен спр.Организации.В базе тока одна организация, создаю для этой одной организации ее подразделения:
Код:
СпрПодр = Справочники["ПодразделенияОрганизаций"];
Организ=СпрОрг.НайтиПоКоду("000000001");
если Организ.Пустая() тогда
иначе
сообщить(Организ);
КонецЕсли;	
Для i = 2 по ВсегоСтрок цикл
Значение_X1Y1 = EXCEL_ПолучитьЗначениеЯчейки2 (ТекущаяСтраница, i, 1);
выборка=СпрПодр.Выбрать(,Организ);//на этом этапе Организ именнно та организация, которая нужна.
Пока выборка.Следующий()=1 цикл
НовЭл = СпрПодр.СоздатьЭлемент();
НовЭл.Наименование=сокрлп(Значение_X1Y1);
НовЭл.Записать();
КонецЦикла;
КонецЦикла;
После выполнения этого фрагмента,пишет,что "Владелец не задан или задан неверно!" :)
 
H
#2
Скорей всего тут нада задать владельца

НовЭл = СпрПодр.СоздатьЭлемент();
НовЭл.Владелец = Организ;
НовЭл.Наименование=сокрлп(Значение_X1Y1);
НовЭл.Записать();
 
N

New2011

#3
Скорей всего тут нада задать владельца

НовЭл = СпрПодр.СоздатьЭлемент();
НовЭл.Владелец = Организ;
НовЭл.Наименование=сокрлп(Значение_X1Y1);
НовЭл.Записать();
ларчик так просто открывался,спасибо.
 
Вверх Снизу