1С8. Не добавляются записи в регистр сведений.

  • Автор темы anivaler
  • Дата начала
A

anivaler

Гость
#1
В переменной Городская храню предопределённый элемент справочника Подразделения.
В справочнике ГаражныеНомера реквизит "Колонна" имеет тип СправочникСсылка.Подразделения.
В регистре сведений у меня ни одной записи.

[codebox]Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
//процедура где идет заполнение и проверка записей регистра

Городская = Справочники.Подразделения.КолоннаГородская;
БезШофера = Перечисления.СостояниеАвтобуса.БезШофера;
ТекРемонт = Перечисления.СостояниеАвтобуса.ТекущийРемонт;
КапРемонт = Перечисления.СостояниеАвтобуса.КапитальныйРемонт;
Набор = РегистрыСведений.СвободныеМашиныГород.СоздатьНаборЗаписей();
Набор.Прочитать();
Выборка = Справочники.ГаражныеНомера.Выбрать();
Если Набор.Количество() = 0 Тогда
//Если регистр пустой, то заполняем регистр машинами из ГОРОДСКОЙ колонны. Все с состоянием БЕЗШОФЕРА.

Пока Выборка.Следующий() Цикл
Если Выборка.Колонна = Городская Тогда
НовыйГосНом = Набор.Добавить();
НовыйГосном.ГосНомер = Выборка.Наименование;
НовыйГосНом.СостояниеАвтобуса = БезШофера;
Иначе Продолжить;
КонецЕсли;
КонецЦикла;
Набор.Записать();
Сообщить ("Внимание! В регистре сведений ""Свободные машины город"" нет информации о текущем и капитальном ремонте.",СтатусСообщения.Информация);
КонецЕсли;
КонецПроцедуры;[/codebox]

При создании документа выдаёт ошибку

{Документ.РазнарядкаНаДатуГород.Форма.ФормаДокумента(26)}: Ошибка при вызове метода контекста (Записать): Запись с такими ключевыми полями существует! : (Регистр сведений: Свободные машины город; Номер строки: 2)
Набор.Записать();
по причине:
Запись с такими ключевыми полями существует! : (Регистр сведений: Свободные машины город; Номер строки: 2)

Как такая запись может существовать, если у меня регистр пустой???
В чём дело не подскажете?
Спасибо.
 

tanat

Well-Known Member
02.03.2007
265
0
#4
регистр не переодический - следовательно пара - ключ-значение не уникальны. Сделайте либо переодическим, либо добавьте измерение, которое будет обеспечивать уникальность записи.(например туже дату)