1Сv77 Бухгалтерские итоги

Тема в разделе "1C и всё что с ней связано", создана пользователем Liolik, 2 май 2007.

Статус темы:
Закрыта.
  1. Liolik

    Liolik Гость

    При выносе в колонку спр. Номенклатура остатков по складу происходит торможение работы.
    Код выглядит след. образом:

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьРазделительУчета("");

    Функция ОстатокТовара()
    Если ТекущийЭлемент().ЭтоГруппа() = 1 Тогда
    // по группам не показываем
    Возврат "";
    КонецЕсли;

    Если ВидТМЦ <> Перечисление.ВидыТМЦ.Услуга Тогда
    Возврат Формат(Ит.СКД(Счет,3,,,ТекущийЭлемент(),), "Ч07.3.,");
    КонецЕсли;

    Возврат "";
    КонецФункции

    Прошу подсказать, каким образом увеличить производительность...тормозит не по-детски
     
  2. Mr.X

    Mr.X Гость

    База наверняка у тебя в дбф-е ? На скьюэль работает быстрее. Может быть из-за этого.
     
  3. Liolik

    Liolik Гость

    На dbf, тока по-моему проблема в итогах, может чего не так написано?
     
  4. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Проблема в следующем: Бухитоги у 1С достаточно тормознутая компонента. Бухитоги не хранят актуальных срезов. Как следствие, постоянный пересчет. Естественно, при большом количестве субконто получаем значительные тормоза. Объясняется все достаточно просто: бухгалтерская компонента не предназначена для ведения оперативного учета, т.к. период отчетности (актуальности) в бухучете - месяц. Что касаемо ускорения работы бухитогов под сиквелом... Лично мной замечено, что на некоторых релизах бухитоги под сиквелом расчитываются медленней, чем под ДБФ. Вывод? Либо использовать регистры для оперативных остатков, пытаться как-то обходить постоянный расчет итогов.
     
  5. Manhone

    Manhone Гость

    Попробуй при открытии формы выгружать остатки в таблицу значений, а потом функцией доставать эти самые значения. Тормозить будет только при открытии формы.
     
Загрузка...
Похожие Темы - 1Сv77 Бухгалтерские итоги
  1. klen_
    Ответов:
    1
    Просмотров:
    3.453
  2. raissa
    Ответов:
    5
    Просмотров:
    3.842
Статус темы:
Закрыта.

Поделиться этой страницей