7.7 Глобальный модуль

  • Автор темы Guest
  • Дата начала
G

Guest

#1
Прошу помощщи, голову сломал, сравниваю две таблицы значения, замещщаю в них содержимое ячеек, а при обратной загрузке в табл.часть документа инфа не высвечивается, хотя получена (

Процедура глЗаполнениеТЧдокумента(глДок) Экспорт //Документ "Рекламация" с закладки "Подробности"
ТЗДоп = СоздатьОбъект("ТаблицаЗначений");
глДок.ВыгрузитьТабличнуюЧасть(ТЗДоп);
ТЗДоп.ВыбратьСтроки();

Пока ТЗДоп.ПолучитьСтроку() = 1 Цикл
Стр = ТЗДоп.НомерСтроки;
Тов_=ТЗДоп.ПолучитьЗначение(Стр,"Товар");

ТЗР = СоздатьОбъект("ТаблицаЗначений");//Смотрим ТЗ "косяки"
глФормаТЗ.ВыбратьСтроки();

Пока глФормаТЗ.ПолучитьСтроку() = 1 Цикл
СтрР = глФормаТЗ.НомерСтроки;
Тов_Р = глФормаТЗ.ПолучитьЗначение(СтрР,"Товар");
Сорт = глФормаТЗ.ПолучитьЗначение(СтрР,"Сортировщик");
Метка = глФормаТЗ.ПолучитьЗначение(СтрР,"Метка");
Сообщить(Сорт); // имя работника получено

Если Тов_Р = Тов_ Тогда
Сообщить(Сорт); //значения одинаковые

ТЗДоп.УстановитьЗначение(Стр,"Сортировщик",Сорт); //здесь должна заменить Работника
ТЗДоп.УстановитьЗначение(Стр,"Метка",Метка);
КонецЕсли;
КонецЦикла;
глДок.ЗагрузитьТабличнуюЧасть(ТЗДоп);
КонецЦикла;
глДок.ЗагрузитьТабличнуюЧасть(ТЗДоп); // а при загрузке в табл.части документа не появляется

КонецПроцедуры
 

puh14

Well-known member
11.07.2008
1 412
0
#2
Процедура глЗаполнениеТЧдокумента(глДок) Экспорт //Документ "Рекламация" с закладки "Подробности"
ТЗДоп = СоздатьОбъект("ТаблицаЗначений");
глДок.ВыгрузитьТабличнуюЧасть(ТЗДоп);
ТЗДоп.ВыбратьСтроки();

Пока ТЗДоп.ПолучитьСтроку() = 1 Цикл
Стр = ТЗДоп.НомерСтроки;
Тов_=ТЗДоп.ПолучитьЗначение(Стр,"Товар");

ТЗР = СоздатьОбъект("ТаблицаЗначений");//Смотрим ТЗ "косяки"//Нафига оно надо, если нигде больше в процедуре не используется
глФормаТЗ.ВыбратьСтроки(); // а здесь не ругается? объект-то не создан. Если глобальный то чем наполнен?

Пока глФормаТЗ.ПолучитьСтроку() = 1 Цикл
СтрР = глФормаТЗ.НомерСтроки;
Тов_Р = глФормаТЗ.ПолучитьЗначение(СтрР,"Товар");
Сорт = глФормаТЗ.ПолучитьЗначение(СтрР,"Сортировщик");
Метка = глФормаТЗ.ПолучитьЗначение(СтрР,"Метка");
Сообщить(Сорт); // имя работника получено

Если Тов_Р = Тов_ Тогда
Сообщить(Сорт); //значения одинаковые

ТЗДоп.УстановитьЗначение(Стр,"Сортировщик",Сорт); //здесь должна заменить Работника
ТЗДоп.УстановитьЗначение(Стр,"Метка",Метка);
КонецЕсли;
КонецЦикла;
глДок.ЗагрузитьТабличнуюЧасть(ТЗДоп);// а это зачем? если в конце-концов на две строчки ниже всё перегружается.
КонецЦикла;
глДок.ЗагрузитьТабличнуюЧасть(ТЗДоп); // а при загрузке в табл.части документа не появляется

КонецПроцедуры


Может проще передать в глобальник ТЗ, а по окончании её обработку грузануть уже в документе?