1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

7.7 - Изменение значения ячейки таблицы.

Тема в разделе "Базы данных и администрирование", создана пользователем unknown181538, 24 май 2009.

  1. unknown181538

    unknown181538 НеГуру

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    Есть таблица в режиме ввода данных.
    Заполнение ячейки:
    [codebox]Процедура Заполнить()
    ...
    Для С=1 По Метаданные.Справочник() Цикл
    ....
    Таблица.Область(ПерваяСтрока+С,2).Значение = "*";
    ....
    КонецЦикла;
    ....
    КонецПроцедуры
    [/codebox]

    Далее пытаюсь сделать интерактивное изменение значения:
    [codebox]Процедура ПриВыбореЯчейкиТаблицы(Адрес,Значение)
    Сообщить("!!!");
    Если Прав(Адрес,1) ="2" Тогда
    Если Значение="*" Тогда
    таблица.Область(Адрес).Значение = "-";
    //Значение = 0;
    Иначе
    таблица.Область(Адрес).Значение = "*";
    //Значение = 1;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры [/codebox]

    [codebox]Синтаксис:
    ПриВыбореЯчейкиТаблицы(<Адрес>,<Значение>)
    ...
    <Значение> - здесь в процедуру системой передается значение данной ячейки, а если диаграмма - значение выбранного элемента.[/codebox]
    У меня же в Переменную "Значение ничего не попадает". В чем может быть дело? Вся колонка, которую я заполняю имеет тип "Строка".
     
  2. puh14

    puh14 Well-Known Member

    Репутация:
    0
    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    А условие-то выполняется? глянь в отладчике - может у тебя
    всё рубит.

    Кстати - вроде в режиме ввода данных количество строк в таблице фиксированно -а у тебя заполняется по количеству справочников. зачем так сложно-то?
     
  3. unknown181538

    unknown181538 НеГуру

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    Не рубит. По отладчику видно, что в переменную значение ничего не попадает.
    Нет, не фиксировано - не мучался ты с задачей из спеца по БУ)
    Зачем сложно? Больше для саморазвития - пытаюсь написать универсальную обработку для заполнения базы - решил, что наиболее подходящий интерфейс - с таблицей в режиме ввода.
     
Загрузка...

Поделиться этой страницей