7.7 - Изменение значения ячейки таблицы.

unknown181538

НеГуру
28.12.2008
1 417
0
#1
Есть таблица в режиме ввода данных.
Заполнение ячейки:
[codebox]Процедура Заполнить()
...
Для С=1 По Метаданные.Справочник() Цикл
....
Таблица.Область(ПерваяСтрока+С,2).Значение = "*";
....
КонецЦикла;
....
КонецПроцедуры
[/codebox]

Далее пытаюсь сделать интерактивное изменение значения:
[codebox]Процедура ПриВыбореЯчейкиТаблицы(Адрес,Значение)
Сообщить("!!!");
Если Прав(Адрес,1) ="2" Тогда
Если Значение="*" Тогда
таблица.Область(Адрес).Значение = "-";
//Значение = 0;
Иначе
таблица.Область(Адрес).Значение = "*";
//Значение = 1;
КонецЕсли;
КонецЕсли;
КонецПроцедуры [/codebox]

[codebox]Синтаксис:
ПриВыбореЯчейкиТаблицы(<Адрес>,<Значение>)
...
<Значение> - здесь в процедуру системой передается значение данной ячейки, а если диаграмма - значение выбранного элемента.[/codebox]
У меня же в Переменную "Значение ничего не попадает". В чем может быть дело? Вся колонка, которую я заполняю имеет тип "Строка".
 

puh14

Well-known member
11.07.2008
1 412
0
#2
А условие-то выполняется? глянь в отладчике - может у тебя
Если Прав(Адрес,1) ="2" Тогда
всё рубит.

Кстати - вроде в режиме ввода данных количество строк в таблице фиксированно -а у тебя заполняется по количеству справочников. зачем так сложно-то?
 

unknown181538

НеГуру
28.12.2008
1 417
0
#3
А условие-то выполняется? глянь в отладчике - может у тебя
Цитата
Если Прав(Адрес,1) ="2" Тогда
всё рубит.

Кстати - вроде в режиме ввода данных количество строк в таблице фиксированно -а у тебя заполняется по количеству справочников. зачем так сложно-то?
Не рубит. По отладчику видно, что в переменную значение ничего не попадает.
Нет, не фиксировано - не мучался ты с задачей из спеца по БУ)
Зачем сложно? Больше для саморазвития - пытаюсь написать универсальную обработку для заполнения базы - решил, что наиболее подходящий интерфейс - с таблицей в режиме ввода.