1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

7.7 Определить владельца эленмента справочника

Тема в разделе "Базы данных и администрирование", создана пользователем olga13, 1 фев 2011.

  1. olga13

    olga13 Well-Known Member

    Репутация:
    0
    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Всем доброго дня! Подскажите, пожалуйста, как можно определить владельца элемента справочника, если этот элемент еще не записан? Мне нужно в процедуру "ПриЗаписи" вставить проверку, а она срабатывает только в том случае, если элемент уже был сохранен.

    Код:
    Процедура ПриЗаписи()
    Спр = СоздатьОбъект("Справочник.Договора");
    Спр.ИспользоватьВладельца(ТекущийЭлемент().Владелец);
    Спр.ВыбратьЭлементыПоРеквизиту("Фирма", Фирма);
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    Если Спр.ОсновнойДоговор = Перечисление.Булево.Да Тогда
    Предупреждение("У контрагента уже есть основной договор!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
     
  2. Gluk8888

    Gluk8888 Гость

    Репутация:
    0
    просто "Владелец"
     
  3. olga13

    olga13 Well-Known Member

    Репутация:
    0
    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Огромное спасибо за подсказку! Ларчик, оказывается, просто открывался... :)
     
Загрузка...

Поделиться этой страницей