7.7 Определить владельца эленмента справочника

olga13

Well-known member
10.10.2008
208
0
#1
Всем доброго дня! Подскажите, пожалуйста, как можно определить владельца элемента справочника, если этот элемент еще не записан? Мне нужно в процедуру "ПриЗаписи" вставить проверку, а она срабатывает только в том случае, если элемент уже был сохранен.

Код:
Процедура ПриЗаписи()
Спр = СоздатьОбъект("Справочник.Договора");
Спр.ИспользоватьВладельца(ТекущийЭлемент().Владелец);
Спр.ВыбратьЭлементыПоРеквизиту("Фирма", Фирма);
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.ОсновнойДоговор = Перечисление.Булево.Да Тогда
Предупреждение("У контрагента уже есть основной договор!");
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецЦикла;
КонецПроцедуры