7.7 Определить владельца эленмента справочника

Тема в разделе "1C и всё что с ней связано", создана пользователем olga13, 1 фев 2011.

  1. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Всем доброго дня! Подскажите, пожалуйста, как можно определить владельца элемента справочника, если этот элемент еще не записан? Мне нужно в процедуру "ПриЗаписи" вставить проверку, а она срабатывает только в том случае, если элемент уже был сохранен.

    Код ( (Unknown Language)):
    Процедура ПриЗаписи()
    Спр = СоздатьОбъект("Справочник.Договора");
    Спр.ИспользоватьВладельца(ТекущийЭлемент().Владелец);
    Спр.ВыбратьЭлементыПоРеквизиту("Фирма", Фирма);
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    Если Спр.ОсновнойДоговор = Перечисление.Булево.Да Тогда
    Предупреждение("У контрагента уже есть основной договор!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
     
  2. Gluk8888

    Gluk8888 Гость

    просто "Владелец"
     
  3. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Огромное спасибо за подсказку! Ларчик, оказывается, просто открывался... :)
     
Загрузка...

Поделиться этой страницей