7.7 Открытие формы отчета с параметрами

Тема в разделе "1C и всё что с ней связано", создана пользователем olga13, 3 дек 2010.

  1. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Добрый день! Подскажите, пожалуйста, как определить, какое значение передается в "Форма.Параметр"? У меня в одном случае это может быть документ, а в другом отчет. Соответственно, и имена реквизитов, передаваемых в параметрах, разные. Иными словами, как проверить, что Форма.Параметр это "Отчет"?
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    ТипЗначения()
    ТипЗначенияСтр()
     
  3. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    ТипЗначения() пробовала, он почему-то всегда 100, и для документа тоже.
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Выложите код открытия формы.
     
  5. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Код ( (Unknown Language)):
    Процедура ПриОткрытии()
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    Если ТипЗначенияСтр(Форма.Параметр) = "ГрупповойКонтекст" Тогда
    Контрагент = Форма.Параметр.Клиент;
    Фирма = Константа.ОснФирма;
    ЦФУ = Форма.Параметр.ЦФУ;
    Дата1 = Форма.Параметр.Дата1;
    Дата2 = Форма.Параметр.Дата2;
    Валюта = Константа.ОсновнаяВалютаБухг;
    ИначеЕсли (Форма.Параметр.Вид() = "РасходнаяКредит") или (Форма.Параметр.Вид() = "Счет") Тогда
    Контрагент = Форма.Параметр.Контрагент;
    Фирма = Константа.ОснФирма;
    ЦФУ = Форма.Параметр.ЦФУ;
    Дата1 = НачМесяца(Форма.Параметр.ДатаДок);
    Дата2 = КонМесяца(Форма.Параметр.ДатаДок);
    Валюта = Форма.Параметр.Валюта;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    На ИначеЕсли выполнение не идет и в случае открытия из документа выдает ошибку.
     
  6. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    ТипЗначенияСтр(Форма.Параметр) = "ГрупповойКонтекст" всегда при передаче в качестве параметра формы документа, справочника, отчета.
    Что отличить одно от другого я делаю:
    ЭтоДок = 1; // признак Дока
    Попытка
    Д = Форма.Параметр.ДатаДок;
    Исключение
    ЭтоДок = 0;
    КонецПопытки;
     
  7. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    А если документ не записан?
     
  8. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Усе буде добра.
    Форма тоже имеет этот параметр.
     
  9. olga13

    olga13 Well-Known Member

    Регистрация:
    10 окт 2008
    Сообщения:
    208
    Симпатии:
    0
    Спасибо за подсказку
     
Загрузка...

Поделиться этой страницей