• Paranoid - курс по анонимности и безопасности в сети от команды codeby. Защита персональных данных, анонимность в сети интернет, настройка виртуальных машин, безопасная передача данных, анти форензика и еще много всего полезного. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

8.2 Помогите С Процедурой

  • Автор темы valleha
  • Дата начала
Статус
Закрыто для дальнейших ответов.
V

valleha

#1
Помогите разобраться с задачей. Перепробывал много вариантов, но так как я новичёк, ответа так и не нашёл.

Необходимо в табличной части справочника, перед удалением строк(и) выдать в сообщении пользователю информацию о строках, которые удаляются.





Код:
&НаКлиенте
Процедура ПередУдалением(Элемент) 

Сообщить(Колонка1+" "+Колонка2+" удалено");	


КонецПроцедуры
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
и в чем же собственно проблема заключается?
 
V

valleha

#4
Сообщить(ЭлементыФормы.ТекущиеДанные.НомерСтроки);

: Переменная не определена (ЭлементыФормы)
Сообщить(<<?>>ЭлементыФормы.ТекущиеДанные.НомерСтроки); (Проверка: Тонкий клиент)


Добавлено: Ок, спасибо, unknown181538.


Код:
&НаКлиенте
Процедура ПередУдалением(Элемент) 

Сообщить(Элемент.ТекущиеДанные.НомерСтроки); 	


КонецПроцедуры
 
V

valleha

#5
Код:
&НаКлиенте
Процедура ПередУдалением(Элемент) 

Сообщить(Элемент.ТекущиеДанные.НомерСтроки); 	


КонецПроцедуры
[/quote]



....а если не одна строка, а несколько???
 

unknown181538

НеГуру
28.12.2008
1 417
0
#6
что-то я не то написал...
так ТекущиеДанные - это данные текущей строки, т.е. той, которая удаляется
 
V

valleha

#7
Я имею ввиду, что если выбрать для удаления две или более строк сразу, то

Код:
Сообщить(Элемент.ТекущиеДанные.НомерСтроки);
обрабатывает только одну строку. Как быть в этом случае?
 

Darlock

Well-known member
04.01.2008
560
1
#9
"Элемент" - коллекция всех элементов формы. В данном случае таблица, значит несколько строк может быть выделено. Свойство "ВыделенныеСтроки" доступно для данного жлемента управления.

Код:
Для Каждого УдаляемаяСтрока Из Элементы.ИмяЭУТаблицы.ВыделенныеСтроки Цикл
...
КонецЦикла;
И лучше это вынести в отдельную процедуру/команду, потому как метод "ПередУдалением" - Штатный обработчик и вызывается для конкретно удаляемой строки.
 
Статус
Закрыто для дальнейших ответов.
Вверх Снизу