1. Наш канал codeby в telegram. Пишем об информационной безопасности, методах защиты информации, о программировании. Не пропускай новости с кодебай, будь в тренде ! Подробнее ...

    Скрыть объявление

8.2 Помогите С Процедурой

Тема в разделе "Базы данных и администрирование", создана пользователем valleha, 28 окт 2011.

Статус темы:
Закрыта.
  1. valleha

    valleha Гость

    Репутация:
    0
    Помогите разобраться с задачей. Перепробывал много вариантов, но так как я новичёк, ответа так и не нашёл.

    Необходимо в табличной части справочника, перед удалением строк(и) выдать в сообщении пользователю информацию о строках, которые удаляются.





    Код:
    &НаКлиенте
    Процедура ПередУдалением(Элемент) 
    
    Сообщить(Колонка1+" "+Колонка2+" удалено");	
    
    
    КонецПроцедуры
     
  2. KiR

    KiR НЕ шибка опытный програмер)

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    и в чем же собственно проблема заключается?
     
  3. unknown181538

    unknown181538 НеГуру

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    Сообщить(ЭлементыФормы.ТекущиеДанные.НомерСтроки);
     
  4. valleha

    valleha Гость

    Репутация:
    0

    : Переменная не определена (ЭлементыФормы)
    Сообщить(<<?>>ЭлементыФормы.ТекущиеДанные.НомерСтроки); (Проверка: Тонкий клиент)


    Добавлено: Ок, спасибо, unknown181538.


    Код:
    &НаКлиенте
    Процедура ПередУдалением(Элемент) 
    
    Сообщить(Элемент.ТекущиеДанные.НомерСтроки); 	
    
    
    КонецПроцедуры
     
  5. valleha

    valleha Гость

    Репутация:
    0
    Код:
    &НаКлиенте
    Процедура ПередУдалением(Элемент) 
    
    Сообщить(Элемент.ТекущиеДанные.НомерСтроки); 	
    
    
    КонецПроцедуры
    [/quote]



    ....а если не одна строка, а несколько???
     
  6. unknown181538

    unknown181538 НеГуру

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    что-то я не то написал...
    так ТекущиеДанные - это данные текущей строки, т.е. той, которая удаляется
     
  7. valleha

    valleha Гость

    Репутация:
    0
    Я имею ввиду, что если выбрать для удаления две или более строк сразу, то

    Код:
    Сообщить(Элемент.ТекущиеДанные.НомерСтроки);
    обрабатывает только одну строку. Как быть в этом случае?
     
  8. unknown181538

    unknown181538 НеГуру

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    У "элемент" есть что-нибудь вроде "ВыделенныеСтроки"?
     
  9. Darlock

    Darlock Well-Known Member

    Репутация:
    0
    Регистрация:
    4 янв 2008
    Сообщения:
    560
    Симпатии:
    1
    "Элемент" - коллекция всех элементов формы. В данном случае таблица, значит несколько строк может быть выделено. Свойство "ВыделенныеСтроки" доступно для данного жлемента управления.

    Код:
    Для Каждого УдаляемаяСтрока Из Элементы.ИмяЭУТаблицы.ВыделенныеСтроки Цикл
    ...
    КонецЦикла;
    И лучше это вынести в отдельную процедуру/команду, потому как метод "ПередУдалением" - Штатный обработчик и вызывается для конкретно удаляемой строки.
     
Загрузка...
Похожие Темы - Помогите Процедурой
  1. ~localhost
    Ответов:
    2
    Просмотров:
    57
  2. citizenfour
    Ответов:
    1
    Просмотров:
    67
  3. Tayrus
    Ответов:
    1
    Просмотров:
    78
  4. Lcf11
    Ответов:
    2
    Просмотров:
    82
  5. Tayrus
    Ответов:
    3
    Просмотров:
    109
Статус темы:
Закрыта.

Поделиться этой страницей