• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

9.0.1 Feature Pack 10 Eclipse Platform Upgraded to 4.6.2

oshmianski

Достойный программист
Lotus team
25.04.2012
563
9
#1
Доброго времени.

Для просмотра контента необходимо: Войти или зарегистрироваться


В том числе...
2) Eclipse Platform Upgraded to 4.6.2 - The 9.0.1 FP10 platform is upgraded from Eclipse 3.4.2 to Eclipse 4.6.2. This includes SWT, OSGi, Jface and other re-lated Eclipse plugins. Notes, Designer, Embedded Sametime, and Connections Plugins now leverage Eclipse 4.6.2. The Domino server uses the OSGi bundles from Eclipse 4.6.2 for servlet and XPages access.
Что-то не нашел в чем отличие Eclipse 3.4.2 от Eclipse 4.6.2.

Чего ждать?
Опять будут грабить? (с)
 

garrick

Lotus team
26.10.2009
911
62
#2
Наконец-то в Дизайнере будет работать компилятор Java 1.8
Интересно, XPages на JSF 2.2 перевести не планируют?
 

savl

Lotus team
28.10.2011
2 138
105
#6
вчера слил, но не ставил еще, все думаю...
Смущает пункт, что запускать приложения после перекомпилирования можно только на FP8 и выше...
Понимаю, что это если ты используешь java 1.8, но мало ли как меняется компиляция под 1.4 и что будет если запустить на 901 FP4...
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 689
305
#7
Понимаю, что это если ты используешь java 1.8, но мало ли как меняется компиляция под 1.4 и что будет если запустить на 901 FP4...
там нет жвм 1.8 и если не была указана целевая сборка как 1.5 - вылетит по несовместимости жвм (зависит от умолчания при компиляции)

---- Добавлено позже ----

ХотФиксы совсем, для линухов (сервера), не появляются, на "известном" ресурсе :(
для виндятки-то свежий выложили.... ;)
 
Последнее редактирование:

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 689
305
#10
@lmike погоди, так FP есть для lin, может тебе скачать? Part Number знаешь?
увидел такой
DominoServer_901FP10_Linux64
Для просмотра контента необходимо: Войти или зарегистрироваться
CNQ2HEN
Для просмотра контента необходимо: Войти или зарегистрироваться
вот эту но PN
Для просмотра контента необходимо: Войти или зарегистрироваться
нет
и вот эту
Для просмотра контента необходимо: Войти или зарегистрироваться

и клиентский
Для просмотра контента необходимо: Войти или зарегистрироваться

единственный момент - я не знаю, надо ли накатывать все предыдущие HF?
и не знаю что за
Для просмотра контента необходимо: Войти или зарегистрироваться
на mylotus
у мя ПА закончился...
 

savl

Lotus team
28.10.2011
2 138
105
#11
@lmike поставил, как только - то сразу.
На HF может не встать, равно как и на IF, сталкивался: Лучше FP всегда на чистый FP
HF504 не могу посмотреть + не думаю, что это актуально будет.
 
Симпатии: Понравилось lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 689
305
#12
@lmike поставил, как только - то сразу.
На HF может не встать, равно как и на IF, сталкивался: Лучше FP всегда на чистый FP
HF504 не могу посмотреть + не думаю, что это актуально будет.
спасибо
mylotus "актуализирован" ;)
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 689
305
#14
Супер! Всем спасибо, но mylotus лежит ))))))))))
я давно обещал сделать ФП (файло-помойку) но старые железки дохнут, не успел поднять виртуалку, надеюсь сделаю все-таки
ЗЫЖ если есть доступ к стр-ре каталогов mylotus - смогу rsync-нуть , планирую развернуть freenas, сроки пока не указываю

---- Добавлено позже ----

сглазили чтоль - поднялся, но список файлов пуст
 
Последнее редактирование:
Симпатии: Понравилось alexas1

savl

Lotus team
28.10.2011
2 138
105
#15
Известные проблемы FP10:
  • (fix available) The IBM Sametime client embedded within the IBM Notes client stops working after you install Notes 9.0.1 FP10 on top of Lotus Notes 9.0.1 FP9 + Sametime Embedded build 9.0.x clients
    Для просмотра контента необходимо: Войти или зарегистрироваться
  • (verified by L2) SMTP Mails with Umlauts broken after installing FP10 This seems to be regression. Support is working.
  • (verified) Group iQ.Suite - Out of License because the internal product numbering has changed. The API reports a different version number.
    Before upgrade eg 9.0.1.9.0.0 => 9.0.1 FP9, after upgrade 900.0.11.0.0.0 => 9.0.1 FP10
    Group is informed and can assist. Group will provide Hotfixes of iQ.Suite (19.1.5, 20.2.3 or 20.3) soon.
  • (not yet verified) org.eclipse.core.runtime.CoreException: Plug-in
    Для просмотра контента необходимо: Войти или зарегистрироваться
    .api was unable to load class
    Для просмотра контента необходимо: Войти или зарегистрироваться
    .domino.osgi.widgets.UpdateWidgetsTask.
    Also custom plugins are broken.
  • (not yet verified) DOTS Task is crashing during startup (OSGI Plugins disappear), s.a.a.
  • (not yet verified) Uninstall of FP10 not possible.
    From scratch reinstall required.
  • (pending) Regarding Mailsploit, the remediation will be included in an FP10 interim fix. Development working on it through SPR #JBAMATTKY3.
 

savl

Lotus team
28.10.2011
2 138
105
#16
Выпустили Fix, для всякой ерунды, кроме темы письма =)

Notes and Domino 9.0.1 IF1 has been released

Domino Server 9.0.1 IF1
PPUEASMHAW Fixed a potential security vulnerability with the IBM Domino Diagnostics service Security Bulletin: IBM Notes NSD Privilege Escalation (technote 2010777)
PPUEASUDSF Fixed a potential security vulnerability with the IBM Domino Diagnostics service Security Bulletin: IBM Notes Privilege Escalation in IBM Notes Diagnostics service (technote 2010767)
MKINAUWTG4 Fixed a potential Server memory leak
DVDI9UNH38 Fixed a potential Server crash
JBAMAVKUPX Fixed an issue where the subject line encoded (UTF-8) after upgrading to Domino 9.0.1FP10
KBRNAVLMA3 Fixed an issue where the version string returned was incorrect with the API NSFDbGetMajMinVersion after upgrading to Domino 9.0.1FP10

Notes Client 9.0.1 IF1
PPUEASMHAW Fixed a potential security vulnerability with the IBM Domino Diagnostics service Security Bulletin: IBM Notes NSD Privilege Escalation (technote 2010777)
PPUEASUDSF Fixed a potential security vulnerability with the IBM Domino Diagnostics service Security Bulletin: IBM Notes Privilege Escalation in IBM Notes Diagnostics service (technote 2010767)
PPUEASNC5D Fixed a potential security vulnerability with the IBM Notes Smart Update Service Security Bulletin: IBM Notes Privilege escalation in IBM Notes Smart Update Service (technote 2010775)
KBRNAVLMA3 Fixed an issue where the version string returned was incorrect with the API NSFDbGetMajMinVersion after upgrading to Domino 9.0.1FP10
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 689
305
#17
ну я "долго" думал и поставил 901FP8HF476-linux64 в контейнер... ;)
причем только на запасном сервере, на основном так и крутится ФП7
 
Вверх Снизу