Агент After Documents Are Created Or Modified

xKlonx

Lotus team
10.09.2009
410
0
#1
Товарищи,создал агент After documents are created or modified. а он не хочет срабатывать.Когда запускаешь ручками все работает,может что - то не так делаю??????Заранее спасибо!!!
 

ToxaRat

Чёрный маг
Lotus team
06.11.2007
3 231
17
#2
а ты его через консоль запусти и увидишь
tell amgr run "db.nsf" 'agent'
 

xKlonx

Lotus team
10.09.2009
410
0
#3
Очень извиняюсь за тупой вопрос,а где находится консоль.Никогда не пользовался
 

TIA

:-)
Lotus team
15.05.2009
790
3
#4
В настройках агента сказано:

By default, this agent will execute at intervals of 30 minutes - not
immediately after each document update. There is also a default
minimum delay of 5 minutes in processing any new or modified
document. These values may be customized in the runtime
environment and will also be impacted by system load.

Т.е. агент реально будет запущен не сразу, а через 5-30 минут.
Доступ к консоли сервера осуществляется через административного клиента.
 

xKlonx

Lotus team
10.09.2009
410
0
#5
А, агент может не работать если база лежит локально????
 

ToxaRat

Чёрный маг
Lotus team
06.11.2007
3 231
17
#6
А, агент может не работать если база лежит локально????
если локально я бы сказал, что она будет работать только если вы включили такую возможность и настроили клиент на работу локальных агентов, а если вы это не делали то точно по дефоулту не будет работать
 

TIA

:-)
Lotus team
15.05.2009
790
3
#7
А, агент может не работать если база лежит локально????
Может. Чтоб запускался на локале в его настройках должен быть указан сервер "Local" и ntaskldr.exe запущен.
Ntaskldr.exe запускается при старте Notes, если в "user preference"s стоит галка "Enable scheduled local agents".
 

xKlonx

Lotus team
10.09.2009
410
0
#8
TIA
Может. Чтоб запускался на локале в его настройках должен быть указан сервер "Local" и ntaskldr.exe запущен.
Ntaskldr.exe запускается при старте Notes, если в "user preference"s стоит галка "Enable scheduled local agents".
Указан "Local" ntaskldr.exe - запущен смотрел процессы.Галку "Enable scheduled local agents" если честно не нашол, у меня клиент 8.5
 

xKlonx

Lotus team
10.09.2009
410
0
#11
Где находится галочка "Enable scheduled local agents"???Сорь но уже все настройки перекопал и не нашол :(
 

xKlonx

Lotus team
10.09.2009
410
0
#13
Проделал всё как написано,не работает ни агент по расписанию, ни "After Documents Are created or modificated".Может глюк клиента.На сервере попытаюсь запустить
 

xKlonx

Lotus team
10.09.2009
410
0
#15
Alexander (Criz)
Что в логах? Что делает агент?
Агент напоминалка,каждый день отправляет уведомление на почту персоналу

Может и работает, но не делает то что вы от него ожидаете?
Но когда ручками запускаю работает же
 

TIA

:-)
Lotus team
15.05.2009
790
3
#16
Но когда ручками запускаю работает же
Ничего это не значит. Запуск в UI (в интерфейсе пользователя) и в BE (фоново) -- огромная разница. Например в BE нельзя использовать UI-объекты. Вы всё проверили, что написано по ссылке OKEN?
 

xKlonx

Lotus team
10.09.2009
410
0
#17
Все пересмотрел,по всем правилам должно работать, а не работает :lol:
 

xKlonx

Lotus team
10.09.2009
410
0
#19

Klido

не пора ли код показать?
Код нормально работает.UI не использовал.Тестировал и другие агенты для отправки сообщения на почту,тоже не работает.Может прикол с клиентом лотуса???
 

ToxaRat

Чёрный маг
Lotus team
06.11.2007
3 231
17
#20
Код нормально работает.UI не использовал.Тестировал и другие агенты для отправки сообщения на почту,тоже не работает.Может прикол с клиентом лотуса???
если настройку на клиенте как включить агенты не нашел, то работать не будет