Агент Не Снимает Выделения Документов

Тема в разделе "Lotus - Программирование", создана пользователем Akupaka, 10 окт 2011.

  1. Akupaka

    Akupaka А че я?.. О.о

    Регистрация:
    4 окт 2007
    Сообщения:
    3.373
    Симпатии:
    2
    Всем привет!

    Поясните мне, глупому, пожалуйста. В каких случаях агент запущенный на выделенных документах не снимает с них выделение?
    У меня сложилось стойкое мнение, что агент справляется с этим без каких-либо необходимых действий с моей стороны, но иногда, например, при ошибке во время выполнения, он этого не делает.
    Не пойму вот, это всегда так было?

    Добавлено: Да и без ошибок, похоже, тоже не всегда снимает...
     
  2. nvyush

    nvyush Lotus team
    Lotus team

    Регистрация:
    22 апр 2009
    Сообщения:
    2.317
    Симпатии:
    0
    notesUIView.DeselectAll не помогает?
     
  3. Akupaka

    Akupaka А че я?.. О.о

    Регистрация:
    4 окт 2007
    Сообщения:
    3.373
    Симпатии:
    2
    nvy ,
    пока вопрос стоит в том, кто верблюд :) Действительно ли меня глючит и агент не должен снимать выделение?
     
  4. Anatoly

    Anatoly Well-Known Member

    Регистрация:
    30 мар 2007
    Сообщения:
    204
    Симпатии:
    0
    Заметил:
    1) Агент запускается через "simple action" - выделение документов остается
    2) Меняю на @Command([RunAgent]) - выделение сбрасывается.
     
  5. Akupaka

    Akupaka А че я?.. О.о

    Регистрация:
    4 окт 2007
    Сообщения:
    3.373
    Симпатии:
    2
    Я агент дергаю из меню Action, т.е. с помощью меню, которое нотес создает сам динамически.
    Вот в одной БД у меня выделения снимаются, а в другой нет :)
     
Загрузка...

Поделиться этой страницей