1. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

Агент перестает работать после обновления шаблоном

Тема в разделе "Lotus - Программирование", создана пользователем SkyDream, 22 апр 2008.

Статус темы:
Закрыта.
  1. SkyDream

    SkyDream Гость

    Репутация:
    0
    Агент перестает работать после обновления шаблоном

    Создал в шаблоне почтовой базы Агент который отрабатывает по событию Before new mail arrives

    Агент перестает работать после обновления шаблоном

    После обновления почтовый базы шаблоном агент теряет сво-во по умолчанию пропадает галочка и он не работает:

    Агент перестает работать после обновления шаблоном

    Помогите разобраться в чем ошибка?

    в ручную все нормально обновляется, проблема при обновлении на сервере из команднеой строки:

    Код:
    lo design -f mail\mailDB
     
  2. morpheus

    morpheus скриптописец

    Репутация:
    0
    Регистрация:
    7 авг 2006
    Сообщения:
    3.915
    Симпатии:
    1
    Видимо подписан тем кто не может его запускать?
     
  3. SkyDream

    SkyDream Гость

    Репутация:
    0
    с подписями все нормально, в ручную пересохраняю агент в базе и он работает и галочка появляется
     
  4. Medevic

    Medevic Что это ? :)
    Lotus team

    Репутация:
    0
    Регистрация:
    10 дек 2004
    Сообщения:
    3.346
    Симпатии:
    2
    В базе может быть только один Before new mail arrives агент. Может у тебя уже есть такой?
     
  5. SkyDream

    SkyDream Гость

    Репутация:
    0
    один агент такой, непонятно почему пропадает эта стрелочка
     
  6. Sandr

    Sandr Гость

    Репутация:
    0
    Посмотрите в самом шаблоне, там все нормально?
     
  7. SkyDream

    SkyDream Гость

    Репутация:
    0
    что именно должно быть нормальным? агент установлен по умолчанию, после обновления рабочей базы в рабочей базе теряется это сво-во
     
  8. nnikishi

    nnikishi Гость

    Репутация:
    0
    Наследование дизайна точно стоит в свойствах БД на этот шаблон? Сделайте ручками Replace Design а потом посмотрите как будет отрабатывать задача Design
     
  9. SkyDream

    SkyDream Гость

    Репутация:
    0
    в ручную все нормально обновляется, проблема при обновлении на сервере из команднеой строки:

    Код:
    lo design -f mail\mailDB
     
  10. Sandr

    Sandr Гость

    Репутация:
    0
    Может у Вас еще один шаблон с таким именем на сервере есть?
     
  11. SkyDream

    SkyDream Гость

    Репутация:
    0
    нету, шаблон всего один на сервере
     
  12. Sandr

    Sandr Гость

    Репутация:
    0
    Вы ручками (когда все работает) дизайне рефрешь делали, или реплейс?
    На сервере Вы делаете рефреш... Напишите агентик, который будет делать ей реплейс дизайн от имени сервера.. вот и посмотрите, как оно будет работать...
     
  13. SkyDream

    SkyDream Гость

    Репутация:
    0
    что то я не нашел в хелпе код для решфреша или реплейса дизайна
     
  14. Sandr

    Sandr Гость

    Репутация:
    0
    Сори, команда такая есть, но вот без участия юзера все же не выйдет..

    Н авсякий случай @Command( [DesignReplace] )
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей