Alsa на Debian Gnu/linux

  • Автор темы Froex
  • Дата начала
Статус
Закрыто для дальнейших ответов.
F

Froex

#1
Ноутбук acer travelmate 2480. Система: debian GNU/Linux lenny (также все нижесказанное справедливо и для etch)
Код:
$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
добавляю в /etc/rc.local строки
Код:
rmmod snd_hda_intel
modprobe snd_hda_intel
скачиваю с alsa-project.org файлы alsa-driver, alsa-lib, alsa-utils и устанавливаю обычыми
Код:
./configure
make
make install
единственное, что для alsa-driver делаю по-другому:
Код:
#./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)
конфигурирование и установка проходят успешно.
перезагружаю компьютер, но возникают следующие проблемы:
1. dmesg не выдает ничего, начинающегося с snd_ (да и связанного со звуком тоже вроде не нашел)
2. в настройках миксера есть только устройство default, но должно быть hda_intel (вроде так называется)
3. звука, конечно, нет )))

Еще пробовал alsaconf - проблемы остались.

Что я мог сделать не так и как решить проблему? Первостепенно хотелось бы знать, почему миксер не видет устройства?
 
F

Froex

#2
Проблему решил. Забыл просто одну вещь:
Код:
#vim /etc/modprobe.d/alsa-base
и добавил в конец файла:
Код:
options snd-hda-intel model=laptop
Это конкретно для моего случая, т.к. у меня такая карточки и такая модель. По-моему, там еще может быть model=stack3, stack4 или stack6, а также какие-то другие модели.

P.S. Спасибо тем, кто хоть тему просматривал )))))

Модерам: можете добавить к названию темы слово "решено" и убрать эту строчку?
 
Статус
Закрыто для дальнейших ответов.