• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фаззинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь. Мобильный клиент для IOS находится в itunes по этой ссылке

apt-get Kali Linux 2018.2

stormLinux

New member
20.07.2018
4
2
#1
Здравствуйте!
У меня возникла проблема решил поставить себе недавно Kali 2018.2 значит поставил я ее
решил сразу Tor воткнуть ввожу

apt-get install tor

и получаю в ответ такое

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Package tor is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'tor' has no installation candidate

как решить? и связано ли это с тем что при установки данной ОС шаг где нужно было выбирать зеркало с доп пакетами APT был пропущен
 

ghost

penetration testing
Red Team
12.05.2016
1 430
2 656
#2
Проверь чтобы репозитории в /etc/apt/sources.list имели такой вид (только такой, всё остальное сотри и ничего более добавлять нельзя!):

Код:
deb https://http.kali.org/kali kali-rolling main non-free contrib
# deb-src https://http.kali.org/kali kali-rolling main non-free contrib
Затем подключись к интернету и выполни:

Код:
apt-get update && apt-get dist-upgrade
При установке выбирать зеркало с доп пакетами APT не обязательно. Ни разу не выбирал. Всё работает.
 

stormLinux

New member
20.07.2018
4
2
#3
Проверь чтобы репозитории в /etc/apt/sources.list имели такой вид (только такой, всё остальное сотри и ничего более добавлять нельзя!):

Код:
deb https://http.kali.org/kali kali-rolling main non-free contrib
# deb-src https://http.kali.org/kali kali-rolling main non-free contrib
Затем подключись к интернету и выполни:

Код:
apt-get update && apt-get dist-upgrade
При установке выбирать зеркало с доп пакетами APT не обязательно. Ни разу не выбирал. Всё работает.
root@MrStorm:~# /etc/apt/sources.list
bash: /etc/apt/sources.list: Отказано в доступе
вот что получилось я нашел sources.list сделал как ты порекомендовал но получил следущее
root@MrStorm:~# apt-get update && apt-get dist-upgrade
E: Драйвер для метода /usr/lib/apt/methods/https не найден.
N: Is the package apt-transport-https installed?
 

ghost

penetration testing
Red Team
12.05.2016
1 430
2 656
#4
root@MrStorm:~# /etc/apt/sources.list
bash: /etc/apt/sources.list: Отказано в доступе
вот что получилось я нашел sources.list сделал как ты порекомендовал но получил следущее
root@MrStorm:~# apt-get update && apt-get dist-upgrade
E: Драйвер для метода /usr/lib/apt/methods/https не найден.
N: Is the package apt-transport-https installed?
Файл /etc/apt/sources.list редактируй в leafpad, если не умеешь пользоваться nano:

Код:
nano /etc/apt/sources.list
Тебе терминал написал, что у тебя пакет apt-transport-https не установлен. Он нужен для получения обновлений по https
Но ты его сейчас и не поставишь. Поэтому в /etc/apt/sources.list измени содержимое на:

Код:
deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib
Видна разница? Я буквы s убрал в репозиториях. Затем обновляйся.
А потом уже устанавливай что душе угодно.
 

SmokeDog

Well-known member
20.06.2018
108
131
#6
root@MrStorm:~# /etc/apt/sources.list
bash: /etc/apt/sources.list: Отказано в доступе
вот что получилось я нашел sources.list сделал как ты порекомендовал но получил следущее
root@MrStorm:~# apt-get update && apt-get dist-upgrade
E: Драйвер для метода /usr/lib/apt/methods/https не найден.
N: Is the package apt-transport-https installed?
Наберай перед коммандами
Код:
sudo
 

ghost

penetration testing
Red Team
12.05.2016
1 430
2 656
#7
Наберай перед коммандами
Код:
sudo
В калий линуксе sudo перед командами не нужен. Он же под рутом работает по умолчанию.
Код:
root@MrStorm
Человек попросил помощи. Не вводите его в заблуждение.
 

stormLinux

New member
20.07.2018
4
2
#8
Файл /etc/apt/sources.list редактируй в leafpad, если не умеешь пользоваться nano:

Код:
nano /etc/apt/sources.list
Тебе терминал написал, что у тебя пакет apt-transport-https не установлен. Он нужен для получения обновлений по https
Но ты его сейчас и не поставишь. Поэтому в /etc/apt/sources.list измени содержимое на:

Код:
deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib
Видна разница? Я буквы s убрал в репозиториях. Затем обновляйся.
А потом уже устанавливай что душе угодно.
спасибо большое)))проблему решил благодаря тебе)
 

ghost

penetration testing
Red Team
12.05.2016
1 430
2 656
#9
спасибо большое)))проблему решил благодаря тебе)
Не за что. А теперь, чтобы обновления получать по https установи apt-transport-https
А затем репозитории назад на букву s смени и снова обновись.
 
Вверх Снизу