Бухгалтерские итоги

  • Автор темы Helena
  • Дата начала
Статус
Закрыто для дальнейших ответов.
H

Helena

#1
На строке БИ.ВыбратьСубконто(1); выдается ошибка "Данная операция допустима только в режиме запроса по аналитике !"
Не пойму, где ошибка

БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
БИ.ИспользоватьСубконто(ВидыСубконто.Документ);
БИ.ВыполнитьЗапрос(ДатаОбработкиЗапроса,ДатаОбработкиЗапроса, "ШР",,,,, "С");
БИ.ВыбратьСубконто(1);
Если БИ.ПолучитьСубконто(1,,Спр.ТекущийЭлемент())=1 Тогда
Если БИ.СКД("С")<>0 Тогда
колШт=колШт+1;
КонецЕсли;
КонецЕсли;
 

Zab

Well-known member
07.08.2006
583
0
#2
А на счете ШР есть такие субконто?
Проверь, что возвращает ВыполнитьЗапрос() ... а так вроде, все нормально.
 
H

Helena

#3
А на счете ШР есть такие субконто?
Проверь, что возвращает ВыполнитьЗапрос() ... а так вроде, все нормально.
Субконто такие есть. ВыполнитьЗапрос() возвращает 1. Так и не получилось у меня в разрезе конкретного субконто получить итоги. Воспользовалась общими

И снова о бухгалтерских итогах...
Активы приходуются на 10.8. Затем списываются на МЦ.0Х. Как в ТЗ записать дату поступления на 10.8 и дату выбытия на МЦ.0Х, а так же первоначальную стоимость и стоимость выбытия данного актива?

БИ_МЦ04 = СоздатьОбъект("БухгалтерскиеИтоги");
БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Материалы);
БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
БИ_МЦ04.ВыполнитьЗапрос(,ВыбКонПериода, "МЦ.04",,,,, "СК");
БИ_МЦ04.ВыбратьСубконто(1);
Пока БИ_МЦ04.ПолучитьСубконто(1)=1 Цикл
ТЗ.НоваяСтрока();
ТЗ.Счет = Строка(БИ_МЦ04.Счет);
ТЗ.Материал = Строка(БИ_МЦ04.Субконто(1));
ТЗ.Количество = Строка(БИ_МЦ04.СКД("К"));
БИ_МЦ04.ВыбратьСубконто(2);
БИ_МЦ04.ПолучитьСубконто(2);
ТЗ.Сотр = Строка(БИ_МЦ04.Субконто(2));
КонецЦикла;
 

Zab

Well-known member
07.08.2006
583
0
#4
Если я правильно понял вопрос, то надо сформировать запрос по периодам, и выбирать обороты. Кста, 10.8 корреспондирует с МЦ? Тогда я бы строил запрос по счету 10.8 и анализировал корреспонденции.
 
H

Helena

#5
Почему БИ_МЦ04.ВыбратьПериоды(,1) возвращает 0?

БИ_МЦ04 = СоздатьОбъект("БухгалтерскиеИтоги");
БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Материалы);
БИ_МЦ04.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
БИ_МЦ04.ВыполнитьЗапрос(ВыбНачПериода,ВыбКонПериода, "МЦ.04",,,,"Проводка", "СК");
БИ_МЦ04.ВыбратьПериоды(,1);
Пока БИ_МЦ04.ПолучитьПериод(,)=1 Цикл
...
КонецЦикла;
 

Zab

Well-known member
07.08.2006
583
0
#6
Может небыло движений в этом периоде? И еще, все никак не запомню, но, есть нюанс какой-то в семерке в последовательности открытия выборок: счет, субконто, периоды. Читай ЖКК и экспериментируй. удачки
 
Статус
Закрыто для дальнейших ответов.