Бухгалтерские итоги

  • Автор темы Muller
  • Дата начала
M

Muller

#1
Что делаю не так?

Код:
	БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт);
Оборот = БухИтоги.ДО(); - так работает
ОборотК = БухИтоги.ДО(3); - а как количество так всегда 0.
 
H

Hryv

#4
Тогда все должно работать

для надежности можно явно указать параметры ВыполнитьЗапрос(), но и по умолчанию должно количество считать
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#6
а на данном счете в указанном периоде точно есть остаток колличественный? ибо БухИтоги.ДО() = БухИтоги.ДО(1) и выдает остаток суммовой
 
M

Muller

#7
БухИтоги.ДО() = БухИтоги.ДО(1) и выдает остаток суммовой
остаток количественный есть
 
H

Hryv

#8
по 7 или 8 счету смотрите остатки?

возможно количественный только один из них, а вы смотрите по другому
 

Natalya

Active member
02.02.2008
25
0
#10
Может быть дело в синтаксисе:

ОборотК = БухИтоги.ДО(счет , 3); или ОборотК = БухИтоги.ДО( , 3);
 
K
#11
субконто выбираешь? если да смотри субконто возможно по одному из них учет ведется только по сумме
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#13
Может быть дело в синтаксисе:
это не тот случай, тут немного другой синтакс - в синтакс-помощнике 2 варианта и предлагаемый тобой для БухИт.Рассчитать

Muller, посмотри внимательно по оборотке в конкретный период - может этот остаток списался чем-то еще. и проверь период. в принципе можешь кинуть скрин плана счетов
 
H
#14
в принципе можешь кинуть скрин плана счетов
Присоединяюсь


А еще, если в конфе есть стандартные отчеты, то запустите ОСВ по счету и посмотрите какие остатки и обороты на вашем счете реально есть

Еще можно всю процедуру здесь выложить
 
M

Muller

#15
Конфигурацию пишу с нуля.

Документ Бензин
Код:
Процедура ОбработкаПроведения()
Операция.НоваяПроводка();
Операция.Д*цензура*.Счет = СчетПоКоду("7");
Операция.Кредит.Счет = СчетПоКоду("8");
Операция.Количество = Количество;
Операция.Содержание = Строка(Количество)+"л.";
Операция.Сумма = Сумма;
Операция.СуммаОперации = Сумма;
Операция.Записать();
КонецПроцедуры
Отчёт
Код:
//*******************************************
Процедура Сформировать()
БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");
Таб=СоздатьОбъект("Таблица");
Счета=СоздатьОбъект("Счет.Основной");
период="с "+Строка(ВыбНачПериода)+" по "+Строка(ВыбКонПериода);
Таб.ВывестиСекцию("Шапка");
...
Если ФБен=1 Тогда
Счета.НайтиПоКоду("7");
счёт=Счета.ТекущийСчет();
БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт);
ОборотД = БухИтоги.ДО();
Таб.ВывестиСекцию("Бензин");
БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт,,,,,4);
ОборотД = БухИтоги.ДО(3);
Таб.ВывестиСекцию("БензинЛ");
КонецЕсли;
...
Таб.ТолькоПросмотр(0);
Таб.Опции(0,0);
Таб.Показать("Таблица");
КонецПроцедуры
План счетов (проще не бывает)
Наименования я стёр на картинке


Добавлено:
Muller, посмотри внимательно ... может этот остаток списался чем-то еще.
Чего-то ещё просто нет. Нет ни одной операции, которая списывала бы со счёта №7. Да и зачисляла всего одна.
 
H
#16
Последнее, что могу предположить: в печ. форме в секции "БензинЛ" другая переменная стоит (не ОборотД)

если же все верно и в отладчике БухИтоги.ДО(3) показывает 0, то даже не знаю

вроде все верно и все должно работать
 
M

Muller

#17
печ. форме уже явно написал БухИтоги.ДО(1) и БухИтоги.ДО(3)
БухИтоги.ДО(1) равно 100
БухИтоги.ДО(3) равно 0

в отладчике тоже самое :rolleyes:
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#18
Muller, ты отладчиком смотришь или по печатной форме? на периоды обратил внимание?
 
M

Muller

#19
И отладчиком и печ. формой.
Периоды всякие перепробовал.
Сделал ещё проводку сумма меняется, кол-во всё равно 0.