Бухгалтерские итоги

Тема в разделе "1C и всё что с ней связано", создана пользователем Muller, 21 янв 2010.

  1. Muller

    Muller Гость

    Репутация:
    0
    Что делаю не так?

    Код (Text):
        БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт);
    Оборот = БухИтоги.ДО(); - так работает
    ОборотК = БухИтоги.ДО(3); - а как количество так всегда 0.
     
  2. Hryv

    Hryv Гость

    Репутация:
    0
    по счету установлен количественный учет?
     
  3. Muller

    Muller Гость

    Репутация:
    0
  4. Hryv

    Hryv Гость

    Репутация:
    0
    Тогда все должно работать

    для надежности можно явно указать параметры ВыполнитьЗапрос(), но и по умолчанию должно количество считать
     
  5. Muller

    Muller Гость

    Репутация:
    0
    Явно указал, всё равно 0 :angry2:
     
  6. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    а на данном счете в указанном периоде точно есть остаток колличественный? ибо БухИтоги.ДО() = БухИтоги.ДО(1) и выдает остаток суммовой
     
  7. Muller

    Muller Гость

    Репутация:
    0
    БухИтоги.ДО() = БухИтоги.ДО(1) и выдает остаток суммовой
    остаток количественный есть
    Бухгалтерские итоги
     
  8. Hryv

    Hryv Гость

    Репутация:
    0
    по 7 или 8 счету смотрите остатки?

    возможно количественный только один из них, а вы смотрите по другому
     
  9. Muller

    Muller Гость

    Репутация:
    0
    Количественный только 7, и смотрю 7.
     
  10. Natalya

    Natalya Active Member

    Репутация:
    0
    Регистрация:
    2 фев 2008
    Сообщения:
    25
    Симпатии:
    0
    Может быть дело в синтаксисе:

    ОборотК = БухИтоги.ДО(счет , 3); или ОборотК = БухИтоги.ДО( , 3);
     
  11. kaa

    kaa Гость

    Репутация:
    0
    субконто выбираешь? если да смотри субконто возможно по одному из них учет ведется только по сумме
     
  12. Muller

    Muller Гость

    Репутация:
    0
    Нет. Субконто нет.
     
  13. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    это не тот случай, тут немного другой синтакс - в синтакс-помощнике 2 варианта и предлагаемый тобой для БухИт.Рассчитать

    Muller, посмотри внимательно по оборотке в конкретный период - может этот остаток списался чем-то еще. и проверь период. в принципе можешь кинуть скрин плана счетов
     
  14. Hryv

    Hryv Гость

    Репутация:
    0
    Присоединяюсь


    А еще, если в конфе есть стандартные отчеты, то запустите ОСВ по счету и посмотрите какие остатки и обороты на вашем счете реально есть

    Еще можно всю процедуру здесь выложить
     
  15. Muller

    Muller Гость

    Репутация:
    0
    Конфигурацию пишу с нуля.

    Документ Бензин
    Код (Text):
    Процедура ОбработкаПроведения()
    Операция.НоваяПроводка();
    Операция.Д*цензура*.Счет = СчетПоКоду("7");
    Операция.Кредит.Счет = СчетПоКоду("8");
    Операция.Количество = Количество;
    Операция.Содержание = Строка(Количество)+"л.";
    Операция.Сумма = Сумма;
    Операция.СуммаОперации = Сумма;
    Операция.Записать();
    КонецПроцедуры
    Отчёт
    Код (Text):
    //*******************************************
    Процедура Сформировать()
    БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");
    Таб=СоздатьОбъект("Таблица");
    Счета=СоздатьОбъект("Счет.Основной");
    период="с "+Строка(ВыбНачПериода)+" по "+Строка(ВыбКонПериода);
    Таб.ВывестиСекцию("Шапка");
    ...
    Если ФБен=1 Тогда
    Счета.НайтиПоКоду("7");
    счёт=Счета.ТекущийСчет();
    БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт);
    ОборотД = БухИтоги.ДО();
    Таб.ВывестиСекцию("Бензин");
    БухИтоги.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, счёт,,,,,4);
    ОборотД = БухИтоги.ДО(3);
    Таб.ВывестиСекцию("БензинЛ");
    КонецЕсли;
    ...
    Таб.ТолькоПросмотр(0);
    Таб.Опции(0,0);
    Таб.Показать("Таблица");
    КонецПроцедуры
    План счетов (проще не бывает)
    Наименования я стёр на картинке
    Бухгалтерские итоги

    Добавлено:
    Чего-то ещё просто нет. Нет ни одной операции, которая списывала бы со счёта №7. Да и зачисляла всего одна.
     
  16. Hryv

    Hryv Гость

    Репутация:
    0
    Последнее, что могу предположить: в печ. форме в секции "БензинЛ" другая переменная стоит (не ОборотД)

    если же все верно и в отладчике БухИтоги.ДО(3) показывает 0, то даже не знаю

    вроде все верно и все должно работать
     
  17. Muller

    Muller Гость

    Репутация:
    0
    печ. форме уже явно написал БухИтоги.ДО(1) и БухИтоги.ДО(3)
    БухИтоги.ДО(1) равно 100
    БухИтоги.ДО(3) равно 0

    в отладчике тоже самое :rolleyes:
     
  18. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Muller, ты отладчиком смотришь или по печатной форме? на периоды обратил внимание?
     
  19. Muller

    Muller Гость

    Репутация:
    0
    И отладчиком и печ. формой.
    Периоды всякие перепробовал.
    Сделал ещё проводку сумма меняется, кол-во всё равно 0.
     
  20. Hryv

    Hryv Гость

    Репутация:
    0
    Попробуй посмотреть чему равно СКД(3)
     
Загрузка...

Поделиться этой страницей