БухИтоги

  • Автор темы Butty
  • Дата начала
Статус
Закрыто для дальнейших ответов.
B

Butty

#1
Вот такая проблема. :) Для расчета необходимо найти сумму оборота по счетам 69, 70 по конкретному Сотруднику (он же - Субконто - Справочник "Сотрудники"). Пишу так:

БухИтоги = СоздатьОбъект ("БухгалтерскиеИтоги");
БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник);
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

ПособияНачислены = БухИтоги.ОБ (СчетПоКоду ("70"), СчетПоКоду ("69.3")); // это искомое значение

Но это не правильно. Выдает ошибку. Как написать не знаю! Уже могз закипает! :) Как?! Help...
 

Zab

Well-known member
07.08.2006
583
0
#2
Код:
БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник,2);
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

БухИтоги.ВыбратьСчета();
Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
БухИтоги.ВыбратьКорСчета();
Если БухИтоги.ПолучитьКорСчет(СчетПоКоду("69.3"))=0 Тогда Продолжить; КонецЕсли;

ПособияНачислены = БухИтоги.ОБ(); // это искомое значение
Примерно так. (Это общее направление, код я не запускал.)
 
B

Butty

#3
4 Zab
К сожаленю, так тоже ничего не получается. :)
И еще. Скажите, пожалуйста, какой смысл в следующей записи:
Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
?
 
L
#4
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

Пятый параметр в функции Запрос - Валюта. Вы туда передаете "2" (это как я понял тип итогов - обороты).
Надо так:
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",,2);
 
B

Butty

#5
LSH, да, вы правы. Запрос я исправила. А дальше? Опять не работает. :)
Вот какую ошибку выдает:
ПособияНачислены = БухИтоги.ОБ();
{Документ.ЗарплатаРасчет.Форма.Модуль(82)}: Недостаточное число параметров передано при вызове функции/процедуры объекта

Как получить оборот по счетам в разрезе Субконто??? :)
 
B

Butty

#6
Все заработало! Проблема закрыта. Всем спасибо. :D
 
Статус
Закрыто для дальнейших ответов.