1. Уважаемые участники и гости, 19 октября codeby будет работать в режиме "Только чтение". Регистрация новых участников будет закрыта. 20 октября портал продолжит работу в прежнем режиме.

БухИтоги

Тема в разделе "1C и всё что с ней связано", создана пользователем Butty, 14 мар 2007.

Статус темы:
Закрыта.
  1. Butty

    Butty Гость

    Репутация:
    0
    Вот такая проблема. :) Для расчета необходимо найти сумму оборота по счетам 69, 70 по конкретному Сотруднику (он же - Субконто - Справочник "Сотрудники"). Пишу так:

    БухИтоги = СоздатьОбъект ("БухгалтерскиеИтоги");
    БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник);
    БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

    ПособияНачислены = БухИтоги.ОБ (СчетПоКоду ("70"), СчетПоКоду ("69.3")); // это искомое значение

    Но это не правильно. Выдает ошибку. Как написать не знаю! Уже могз закипает! :) Как?! Help...
     
  2. Zab

    Zab Well-Known Member

    Репутация:
    0
    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Код:
    БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник,2);
    БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);
    
    БухИтоги.ВыбратьСчета();
    Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
    БухИтоги.ВыбратьКорСчета();
    Если БухИтоги.ПолучитьКорСчет(СчетПоКоду("69.3"))=0 Тогда Продолжить; КонецЕсли;
    
    ПособияНачислены = БухИтоги.ОБ(); // это искомое значение
    Примерно так. (Это общее направление, код я не запускал.)
     
  3. Butty

    Butty Гость

    Репутация:
    0
    4 Zab
    К сожаленю, так тоже ничего не получается. :)
    И еще. Скажите, пожалуйста, какой смысл в следующей записи:
    Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
    ?
     
  4. LSH

    LSH Гость

    Репутация:
    0
    БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

    Пятый параметр в функции Запрос - Валюта. Вы туда передаете "2" (это как я понял тип итогов - обороты).
    Надо так:
    БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",,2);
     
  5. Butty

    Butty Гость

    Репутация:
    0
    LSH, да, вы правы. Запрос я исправила. А дальше? Опять не работает. :)
    Вот какую ошибку выдает:
    ПособияНачислены = БухИтоги.ОБ();
    {Документ.ЗарплатаРасчет.Форма.Модуль(82)}: Недостаточное число параметров передано при вызове функции/процедуры объекта

    Как получить оборот по счетам в разрезе Субконто??? :)
     
  6. Butty

    Butty Гость

    Репутация:
    0
    Все заработало! Проблема закрыта. Всем спасибо. :D
     
Загрузка...
Похожие Темы - БухИтоги
  1. Paume
    Ответов:
    3
    Просмотров:
    1.919
Статус темы:
Закрыта.

Поделиться этой страницей