• Paranoid - курс по анонимности и безопасности в сети от команды codeby. Защита персональных данных, анонимность в сети интернет, настройка виртуальных машин, безопасная передача данных, анти форензика и еще много всего полезного. Подробнее ...

Цена

  • Автор темы Roman
  • Дата начала
Статус
Закрыто для дальнейших ответов.
R

Roman

#1
Код:
//*******************************************
Процедура Сформировать()
СпрН = СоздатьОбъект("Справочник.Номенклатура");
СпрН.ВыбратьЭлементы();
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Шапка");
Цена="";
Цена = глПолучитьЦену(СпрН.ТекущийЭлемент(),ТипыЦен,РабочаяДата());
Пока СпрН.ПолучитьЭлемент() = 1 Цикл
Если СпрН.ЭтоГруппа() = 0 Тогда
Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;
Таб.Показать(1);
КонецПроцедуры
Цену выдает равной нулю.
Вопрос- почему.
ТипыЦен = Выбираю в диалоге.
 

Дайнеко

Well-known member
19.11.2009
951
0
#3
puh14 проповедует принцип "Дам направление". Во времена моего обучения гигантские компьютеры часто "висли". Тогда препод говорил: "Отлаживайте всухую". Этот значит нарисовать на бумаге набор исходных данных, потом поводить пальцем по распечатке и высчитать результат.
До сих пор помогает.
 

vbs

Well-known member
18.02.2007
1 708
1
#4
Во времена моего обучения гигантские компьютеры часто "висли".
А мне доводилось лазать по дампу, выведенному на АЦПУ. Длина распечатки достигала нескольких метров :unsure:
А вообще-то, принцип "Дам направление" правилен. Ошибка видна сразу, и задаватель вопроса мог легко сам ее
обнаружить, если бы не ленился.
 
R

Roman

#5
А вообще-то, принцип "Дам направление" правилен. Ошибка видна сразу, и задаватель вопроса мог легко сам ее
обнаружить, если бы не ленился.
Хм.Вообще-то я тему закрыл, кому-то делать просто не фиг. Взял и открыл тему.
 
Статус
Закрыто для дальнейших ответов.