Цена

Тема в разделе "1C и всё что с ней связано", создана пользователем Roman, 21 май 2010.

Статус темы:
Закрыта.
  1. Roman

    Roman Гость

    Код ( (Unknown Language)):
    //*******************************************
    Процедура Сформировать()
    СпрН = СоздатьОбъект("Справочник.Номенклатура");
    СпрН.ВыбратьЭлементы();
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Цена="";
    Цена = глПолучитьЦену(СпрН.ТекущийЭлемент(),ТипыЦен,РабочаяДата());
    Пока СпрН.ПолучитьЭлемент() = 1 Цикл
    Если СпрН.ЭтоГруппа() = 0 Тогда
    Таб.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЦикла;
    Таб.Показать(1);
    КонецПроцедуры
    Цену выдает равной нулю.
    Вопрос- почему.
    ТипыЦен = Выбираю в диалоге.
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Ошибка в моменте определения цены.
     
  3. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    puh14 проповедует принцип "Дам направление". Во времена моего обучения гигантские компьютеры часто "висли". Тогда препод говорил: "Отлаживайте всухую". Этот значит нарисовать на бумаге набор исходных данных, потом поводить пальцем по распечатке и высчитать результат.
    До сих пор помогает.
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    А мне доводилось лазать по дампу, выведенному на АЦПУ. Длина распечатки достигала нескольких метров :unsure:
    А вообще-то, принцип "Дам направление" правилен. Ошибка видна сразу, и задаватель вопроса мог легко сам ее
    обнаружить, если бы не ленился.
     
  5. Roman

    Roman Гость

    Хм.Вообще-то я тему закрыл, кому-то делать просто не фиг. Взял и открыл тему.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей