1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Чищу базу

Тема в разделе "Базы данных и администрирование", создана пользователем Vazzzo, 9 янв 2008.

  1. Vazzzo

    Vazzzo Гость

    Репутация:
    0
    Удалил все элементы справочника принадлежащие группе. А самму группу удалить не могу. Блин, даже в ручную не получается. При попытки поставить пометку на удаление на группе, выдает сообщение "Удаление элемента" и все, ничего не происходит.

    Удалял с помощью обработки


    Процедура Сформировать()


    Абон=СоздатьОбъект("Справочник.Абоненты");
    Абон.ВыбратьЭлементы();
    Док=СоздатьОбъект("Документ");
    р=0;
    Пока Абон.ПолучитьЭлемент()=1 Цикл
    р=р+1;


    Если Абон.Родитель.Наименование = "ГСК" Тогда
    Док.ОбратныйПорядок();
    Док.ВыбратьПоЗначению(НачДата,КонДата,"Абонент",Абон.ТекущийЭлемент());
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если (Док.Вид ()="Договор") тогда
    Сообщить("Удаление "+Абон+" "+Док.НомерДок);
    Абон.Удалить(1);
    Док.Удалить(1);
    //Абон.Родитель.Удалить(1); //не помогает(

    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;



    КонецПроцедуры


    Может кто подскажет что-нить)
     
  2. jj_mail

    jj_mail Гость

    Репутация:
    0
    А в глобальном модуле нет ли процедуры ПриУдаленииЭлемента() ?
    Мож. там чегой-то прописано...
     
  3. Vazzzo

    Vazzzo Гость

    Репутация:
    0
    короче...разобрался...сам затупил) все нормально
     
Загрузка...

Поделиться этой страницей