Чищу базу

  • Автор темы Vazzzo
  • Дата начала
V

Vazzzo

#1
Удалил все элементы справочника принадлежащие группе. А самму группу удалить не могу. Блин, даже в ручную не получается. При попытки поставить пометку на удаление на группе, выдает сообщение "Удаление элемента" и все, ничего не происходит.

Удалял с помощью обработки


Процедура Сформировать()


Абон=СоздатьОбъект("Справочник.Абоненты");
Абон.ВыбратьЭлементы();
Док=СоздатьОбъект("Документ");
р=0;
Пока Абон.ПолучитьЭлемент()=1 Цикл
р=р+1;


Если Абон.Родитель.Наименование = "ГСК" Тогда
Док.ОбратныйПорядок();
Док.ВыбратьПоЗначению(НачДата,КонДата,"Абонент",Абон.ТекущийЭлемент());
Пока Док.ПолучитьДокумент() = 1 Цикл
Если (Док.Вид ()="Договор") тогда
Сообщить("Удаление "+Абон+" "+Док.НомерДок);
Абон.Удалить(1);
Док.Удалить(1);
//Абон.Родитель.Удалить(1); //не помогает(

КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;



КонецПроцедуры


Может кто подскажет что-нить)
 
J

jj_mail

#2
А в глобальном модуле нет ли процедуры ПриУдаленииЭлемента() ?
Мож. там чегой-то прописано...
 
V

Vazzzo

#3
короче...разобрался...сам затупил) все нормально