Чтение Xml - Файла

Дайнеко

Well-known member
19.11.2009
951
0
#1
Читаю ХML:
Код:
	Пока Чтение.Прочитать() Цикл
Сообщить(Чтение.Имя);
Если НЕ Входит(Чтение.Имя, "Стр") Тогда
Продолжить;
КонецЕсли;
.....
Значение = Чтение.ПолучитьАтрибут(Имя);
.....
КонецЦикла;
Сам исходный XML:
<?xml version="1.0"?>
<СчетаРеализации>
<Стр1 СчетРез="90.09" СчетВыр="90.01" СчетНдс="90.02" СчетСто="90.04"/>
<Стр2 СчетРез="91.09" СчетВыр="91.01" СчетНдс="91.02" СчетСто="91.04"/>
</СчетаРеализации>


Проблема в том, вопреки моим ожиданиям цикл проходит в 2 раза больше чем нужно.
Поставил команду Сообщить. Она выдает:
СчетаРеализации
Стр1
Стр1
Стр2
Стр2
СчетаРеализации
 

SeverBap

Well-known member
18.09.2007
451
0
#2
Я обычно такое грохал так:
Код:
ЧтениеХМЛ = Новый ЧтениеXML;
ПараметрыЧтенияХМЛ = Новый ПараметрыЧтенияXML(,,,,,,,,Истина);
ЧтениеХМЛ.ОткрытьФайл(ФайлХМЛ,ПараметрыЧтенияХМЛ);
ДОМ = Новый ПостроительDOM();
ДокументDOM = ДОМ.Прочитать(ЧтениеХМЛ);
СписокСчетаРеализации=ДокументDOM.ПолучитьЭлементыПоИмени("СчетаРеализации");
Для Каждого СчетаРеализации Из СписокСчетаРеализации Цикл
Для Каждого ПараметрУзел Из СчетаРеализации.ДочерниеУзлы Цикл

Если НЕ Входит(ПараметрУзел.ИмяУзла, "Стр") Тогда
Продолжить;
КонецЕсли;

КонецЦикла;
КонецЦикла;