Чтение Xml - Файла

Тема в разделе "1C и всё что с ней связано", создана пользователем Дайнеко, 10 янв 2013.

  1. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Читаю ХML:
    Код ( (Unknown Language)):
        Пока Чтение.Прочитать() Цикл
    Сообщить(Чтение.Имя);
    Если НЕ Входит(Чтение.Имя, "Стр") Тогда
    Продолжить;
    КонецЕсли;
    .....
    Значение = Чтение.ПолучитьАтрибут(Имя);
    .....
    КонецЦикла;
    Сам исходный XML:
    <?xml version="1.0"?>
    <СчетаРеализации>
    <Стр1 СчетРез="90.09" СчетВыр="90.01" СчетНдс="90.02" СчетСто="90.04"/>
    <Стр2 СчетРез="91.09" СчетВыр="91.01" СчетНдс="91.02" СчетСто="91.04"/>
    </СчетаРеализации>


    Проблема в том, вопреки моим ожиданиям цикл проходит в 2 раза больше чем нужно.
    Поставил команду Сообщить. Она выдает:
    СчетаРеализации
    Стр1
    Стр1
    Стр2
    Стр2
    СчетаРеализации
     
  2. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Я обычно такое грохал так:
    Код (Text):
    ЧтениеХМЛ = Новый ЧтениеXML;
    ПараметрыЧтенияХМЛ = Новый ПараметрыЧтенияXML(,,,,,,,,Истина);
    ЧтениеХМЛ.ОткрытьФайл(ФайлХМЛ,ПараметрыЧтенияХМЛ);
    ДОМ = Новый ПостроительDOM();
    ДокументDOM = ДОМ.Прочитать(ЧтениеХМЛ);
    СписокСчетаРеализации=ДокументDOM.ПолучитьЭлементыПоИмени("СчетаРеализации");
    Для Каждого СчетаРеализации Из СписокСчетаРеализации Цикл
    Для Каждого ПараметрУзел Из СчетаРеализации.ДочерниеУзлы Цикл

    Если НЕ Входит(ПараметрУзел.ИмяУзла, "Стр") Тогда
    Продолжить;
    КонецЕсли;

    КонецЦикла;
    КонецЦикла;
     
Загрузка...
Похожие Темы - Чтение Xml Файла
  1. Gudzik11
    Ответов:
    0
    Просмотров:
    1.069
  2. seoman2
    Ответов:
    21
    Просмотров:
    768
  3. admigator
    Ответов:
    10
    Просмотров:
    815
  4. AlexPNZ
    Ответов:
    3
    Просмотров:
    1.601
  5. AlexPNZ
    Ответов:
    0
    Просмотров:
    1.251

Поделиться этой страницей