Что за ошибка?

Тема в разделе "1C и всё что с ней связано", создана пользователем Stim, 10 июн 2007.

  1. Stim

    Stim Гость

    Нужно найти оборот между корреспонденциями. Выдается Такая ошибка:
    Код (Text):
    оборотмеждусчетами=Ит.Об(ВыбСчет,Ит.КорСчет,3);
    {D:\1C\BUH_SAMIK\EXTFORMS\КОРРСЧЕТ.ERT(27)}: Слишком много параметров передано при вызове функции/процедуры объекта
    вот сама программа
    Код (Text):
    Процедура Сформировать()
    Счет=СоздатьОбъект("Счет");
    Cчет.НайтиПоКоду("43");
    ВыбСчет=Счет.ТекущийСчет();
    ИТ=СоздатьОбъект("БухгалтерскиеИтоги");
    Нмк=СоздатьОбъект("Справочник.Номенклатура");
    Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,, 1);
    Ит.ВыполнитьЗапрос(НачДата, КонДата,,,,3);
    Ит.ВыбратьСубконто(ВидыСубконто.Номенклатура);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл
    ПрочиеПоступления=0;
    Ит.ВыбратьСчета();
    Пока Ит.ПолучитьСчет() = 1 Цикл
    Если Ит.Счет=ВыбСчет Тогда
    Д*цензура*овыйОборот=Ит.ДО(3);
    Ит.ВыбратьКорСчета();
    Пока Ит.ПолучитьКорСчет()=1 Цикл
    Если (строка(Ит.КорСчет)="40") или (Строка(Ит.КорСЧет)="43") тогда
    оборотмеждусчетами=Ит.Об(ВыбСчет,Ит.КорСчет,3); //тут выдает ошибку
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    Идея программы в том, что она находит для каждой позиции номенклатуры коресподенцию счета 43 с 40 или 43 и высчитывает оборот между ними. Подскажите что нетак в этой программе?
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    А кто сказал, что Ит.ОБ() работает в режиме запроса? Этот метод работает в режиме временного расчета итогов.
     
  3. Stim

    Stim Гость

    Т.е мне нужно использовать
    Код (Text):
    оборотмеждусчетами=Ит.КорДо(3);
    Но в таком случае у меня получается что
    Код (Text):
    оборотмеждусчетами=Д*цензура*овыйОборот
    почему?
     
  4. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    что "почему"?
     
  5. Stim

    Stim Гость

    оборотмеждусчетами=Д*цензура*овыйОборот - почему так получилось?
    Ведь д*цензура*овый оборот по счету формируется из сумм оборотов счета с корреспнодирующими счетами. Как правильно найти оборот м-у счетом и корреспондирующим счетом. В моем случае почему то получается, что Ит.КорДО(3)=Д*цензура*овому обороту по счету 43
     
Загрузка...

Поделиться этой страницей