документ Чек в ТиС 1С 7.7

  • Автор темы Elll
  • Дата начала
Статус
Закрыто для дальнейших ответов.
E

Elll

#1
идея такая. открывается документ чек, подбор товара происходит с помощью сканера штрих кода. допустим продается товар А и Б. проводим сканером по товару А - он его находит, количество устанавливается 1. проводим еще раз сканером по товара А, не создавая новую строку с данным товаром количество устанавливается 2. Проводим сканером по товару Б, создается новая строка с товаром и количеством 1. потом опять проводим по товару А, программа должна проверить есть ли такой штрих код в других строках, если есть сплюсовать количество, если нет создать новую строку.

я не знаю как осуществить проверку на наличие штрих кода в других строках :huh:
 
K
#2
ищите по товару если есть товар увеличивайте количество
 
E

Elll

#3
а разница есть что по Штрих коду, что по номенклатуре?!... у мя единственная (пока единственная)загвоздка - как сделать проверку существует ли этот товар в таблице
 
J

jcnby

#4
на одном и том же товаре будет один и тот же штрихкод... просто найди табличную часть етого чека ( если он в 1с ) и проверь поиском по таблице ..... ты бы хоть код выложил.... с фрагментом вбиения строки в чек, чтобы нагляднее было)
 

Zab

Well-known member
07.08.2006
583
0
#5
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Если Товар.Штрихкод = ПолученныйШтрихкод Тогда
Количество = Количество + 1;
Возврат;
КонецЕсли;
КонецЦикла;
спр = СоздатьОбъект("Справочник.Номенклатура");
Если спр.НайтиПоРеквизиту("Штрихкод", ПолученныйШтрихкод) =1 Тогда
НоваяСтрока();
Товар = спр.ТекущийЭлемент();
Количество = 1;
Возврат;
КонецЕсли;
// тут сам пиши алгоритм добавления нового элемента, и не обижайся за ошибки в коде, т.к. писал я его под пивом почти в 2 часа ночи...
 
Статус
Закрыто для дальнейших ответов.