документ в журнале проводки не отображаеться

  • Автор темы tarakan
  • Дата начала
T

tarakan

#1
Здраствуйте!

Я к вам обращаюсь за помощью!

Создовая новый документ для авто сервисса "заказНарядыАкты" в конфигурации 1с 7,7 редакции 4,5(7.70.483).
Я придусмотрел как я думал всё!
Но послего его тестирования. Вскрылась недоработка, решения которой я не знаю!
Суть праблеммы при провидения документа - в журнале операции он отображается но в калонке сумма и содержание пусто. В журнале проводок он вовсе не отображает ни чего!

Я сам только не давно стал изучать 1с и всех тонкостей не знаю!
MD программы можно скачать сдесь http://files.mail.ru/K6ZOXF
 
H

Hryv

#2
а документ проводится вообще?

1. В документе должна быть установлена птичка "бухгалтерский учет"
2. В модуле документа должна быть процедура ОбработкаПроведения()
3. ОбработкаПроведения() должна создавать проводки и сохранять операцию: (Операция.Записать())
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#3
я бы еще добавил пункт
4. В обработке проведения Операция.Сумма = ПеременнаяСодержащаяСуммуОперации;
 
T

tarakan

#4
а документ проводится вообще?

1. В документе должна быть установлена птичка "бухгалтерский учет"
2. В модуле документа должна быть процедура ОбработкаПроведения()
3. ОбработкаПроведения() должна создавать проводки и сохранять операцию: (Операция.Записать())

там и так была процедура ОбработкаПроведения() но я всё ровно ещё кое что подделал и вот что получилось:
вроде всё должно работать НО документ ЗаказНарядАкт отображаеться в журнале операции но у него нет ни одной проводки! когда нажимаешь провести он говорит что документ проведён! Но ни одного счёта он при этом не выстовляет!
по это му я как считаю что и из за это в калонке суммы не выстовляеться сумма документа!

Процедура ОбработкаПроведения(ВидыДвижений)

// Проверка заполненности обязательных реквизитов.
Если глВсеРеквизитыДокументаЗаполнены(Контекст,
"Фирма,Склад,Валюта,Контрагент,Договор")=0 Тогда
Возврат;
КонецЕсли;

Если (Склад.РозничныйСклад = 1) Тогда
глНеПроводить(Контекст,"Документ """+ глНазваниеДокументаВЖурнале(Контекст)+""" можно
|оформлять только с оптового склада!");
Возврат;
КонецЕсли;

// Проведение по регистрам оперативного учета.
Если (ПустоеЗначение(ВидыДвижений) = 1) ИЛИ (Найти(ВидыДвижений, "Регистр") <> 0) Тогда
ПроведениеПоРегистрам();

Если СтатусВозврата() = 0 Тогда
Возврат;
КонецЕсли;
КонецЕсли;

Если ДатаДок >= глДатаПоПриказу147 Тогда
СкорретироватьДвиженияПартийПоАвансам();
КонецЕсли;

глПриПроведении(Контекст, ВидыДвижений);

Попытка
Операция.Записать();
Исключение
глНеПроводить(Контекст, ОписаниеОшибки());
КонецПопытки;

КонецПроцедуры //ОбработкаПроведения()

короче проблему это ен решило!

я бы еще добавил пункт
4. В обработке проведения Операция.Сумма = ПеременнаяСодержащаяСуммуОперации;
А вот эту мысль я не совсем понял!
Можно поточнее!???
 

puh14

Well-known member
11.07.2008
1 412
0
#5
ага - у тебя по сути все движения в другие процедуры выведены, часть из них в глобальнике. весь модуль документа покажи.
и из глобальника глПриПроведении(Контекст, ВидыДвижений);
 
H

Hryv

#6
Судя по коду твой документ не создает проводок, а только движения по регистрам
(хотя точно не известно что делают вызываемые процедуры)

Кинь сюда вот такой скриншот своего документа
 

Вложения

  • 59 КБ Просмотры: 23

vbs

Well-known member
18.02.2007
1 708
1
#7
За проведение документа ЗаказНарядАкт
отвечает процедура глобального модуля
глПриПроведении, в которой, в свою очередь, вызывается
глЗаполнитьОперациюПроводками
Если переменная ТаблицаПроводок заполнена правильно, то и операция с проводками будет создана корректно, и Сумма операции будет присутствовать
 
T

tarakan

#8
ага - у тебя по сути все движения в другие процедуры выведены, часть из них в глобальнике. весь модуль документа покажи.
и из глобальника глПриПроведении(Контекст, ВидыДвижений);
Вот смотри: глобальный модуль Посмотреть вложение GlobalModyl.txt
И модуль формы Посмотреть вложение ZakazNarydAkt.txt
 

Вложения

vbs

Well-known member
18.02.2007
1 708
1
#9
В документе ЗаказНарядАкт
ошибка в модуле формы - вместо переменной
ОблагаетсяЕНВД
надо вставить
_ОблагаетсяЕНВД
и не хватает еще одного
КонецЕсли в процедуре ПриИзмененииСклада
 
T

tarakan

#10
Судя по коду твой документ не создает проводок, а только движения по регистрам
(хотя точно не известно что делают вызываемые процедуры)

Кинь сюда вот такой скриншот своего документа
__________.png
 

Вложения

vbs

Well-known member
18.02.2007
1 708
1
#11
И еще проверь, как заполнен реквизит
Фирма.ЮрЛицо.ФормированиеПроводок
 
H
#12
tarakan, птички правильно стоят
проверяй тогда саму программу: то что vbs тебе пишет
 
T

tarakan

#13
В документе ЗаказНарядАкт
ошибка в модуле формы - вместо переменной
ОблагаетсяЕНВД
надо вставить
_ОблагаетсяЕНВД
и не хватает еще одного
КонецЕсли в процедуре ПриИзмененииСклада
Я сделаю проще уберу все эти процедуры!
Но веть не в этом праблемма! ты сам это понимаешь!


И еще проверь, как заполнен реквизит
Фирма.ЮрЛицо.ФормированиеПроводок
а вот этот пункт я не совсем понял?
 

vbs

Well-known member
18.02.2007
1 708
1
#14
У Фирмы есть реквизит ЮрЛицо (Справочник.СвоиЮрЛица), для проведения у этого ЮрЛица должен быть установлен режим формирования проводок
 
T

tarakan

#15
У Фирмы есть реквизит ЮрЛицо (Справочник.СвоиЮрЛица), для проведения у этого ЮрЛица должен быть установлен режим формирования проводок

Так так подожди!
Во первых доукмент Реализация проводиться

А во вторых Где это режим я его найти не могу!??? :) :(
 

vbs

Well-known member
18.02.2007
1 708
1
#16
За проведение документа ЗаказНарядАкт
отвечает процедура глобального модуля
глПриПроведении, в которой, в свою очередь, вызывается
глЗаполнитьОперациюПроводками
Если переменная ТаблицаПроводок заполнена правильно, то и операция с проводками будет создана корректно, и Сумма операции будет присутствовать
Залезь в отладчик и пройдись по процедуре глПриПроведении
Если не поможет, зашли хотя бы неполную базу (если это не коммерческая тайна), а то возишься уже неделю, а там наверняка все не так сложно :)
 

vbs

Well-known member
18.02.2007
1 708
1
#18
1. В модуле формы ЗаказНарядАкт есть синтаксические ошибки
Для их устранения заменить в тексте процедуры ПриИзмененииСклада()

ОблагаетсяЕНВД на _ОблагаетсяЕНВД

И перед
КонецПроцедуры // ПриИзмененииСклада()
Добавить
КонецЕсли
2. КодОперации в ЗаказНарядАкт не заполнен.
Поскольку у тебя один склад, то процедура ПриИзмененииСклада() ни разу не отрабатывает - а КодОперации устанавливается именно в ней.
Этот код
Если _ОблагаетсяЕНВД = 1 Тогда
КодОперации = глКО.РозничнаяПродажаЕНВД;
Иначе
КодОперации = глКО.РозничнаяПродажа;
КонецЕсли;

стоит перенести в Процедуру ВводНового()
Какой КодОперации поставить - на свое усмотрение. Но именно из-за пустого значения КодОперации не формируется ТаблицаПроводок в глобальном модуле
3. Если уж хотел делать по аналогии с Реализацией (а не с РеализацияРозница - ни одного документа в базе нет и проведение его совсем не такое !)
то измени строку 13025 в глобальном модуле на
ВидДокумента="Реализация";
Проводки будут сформированы по аналогии с Реализацией.
В общем, именно там формируется таблица проводок по документу.
Но, похоже, это не твой случай (проводки явно будут не те).
Попробуй вместо вызова из модуля документа "ЗаказНарядАкт" процедуры ГлПриПроведении
сам написать проводки по типу (это только для примера)

Операция.НоваяПроводка();
Операция.Кредит.Счет = СчетПоКоду(НужныйСчет);
Операция.Кредит.Контрагенты = Контрагент;
Операция.Кредит.Договоры = Договор;
Операция.Сумма = Сумма;
Операция.Записать();

и т.д.
А вот какие счета и субконто задействовать в проводках - это к бухгалтерам, иначе получишь "Вещь в себе"
 

vbs

Well-known member
18.02.2007
1 708
1
#19
Кстати, и НДС у тебя не считается, если НеЕНВД = 0
 
T

tarakan

#20
Хм.... Всё сделал кроме 2ого пункта я перенёс процедуру!
только не понял где ставить год операции!?и что за код опирации?

Да и последний пункт мне совсем не нравиться!
Ведь формирования проводок и так должна проводиться в глобальном модуле!

Да и я спрашивал у бухгалтера! она сказала что проводки должны быть всё теже что и в ДокументеРеализация.
Как она мне обьяснила что там так же идёт списания товара! и так же идут продажи услуг!