• Paranoid - курс по анонимности и безопасности в сети от команды codeby. Защита персональных данных, анонимность в сети интернет, настройка виртуальных машин, безопасная передача данных, анти форензика и еще много всего полезного. Подробнее ...

[domino Designer]Не могу открыть Xpage в браузере!:(

  • Автор темы SiM22
  • Дата начала
Статус
Закрыто для дальнейших ответов.
S

SiM22

#1
Привет. Сабж....
Система Win2003, Lotus 8.5(server+designer).
Создаю приложение на Local сервере, создаю к нему xPage с простым текстом "hello world". Клацаю Design->Preview in browser->Internet Exlorer, выходит ошибка: "To successfully preview this element in a Web browser, please add(or modifi) the ACL entry for Anonymus(or the default ACL) to have at least Author access with the ability to create documents." - исходя из этого я понимаю, что нада зайти кликнуть правой по проекту зайти в Access Control, дать права на создание документов Default'у ? так и делаю, дальше опять иду в Preview, грузится IE....и отвечает мне "The page cannot be found". O_O Как же так?!!!!!!!!!!!!!!!! Смотрю логи сервера они говорят тоже самое!!! "HTTP Web Server: Lots Exception - File does not exist [test.nsf/go.xsp]". Почему все так сложно......где я ошибаюсь? Достаточно ли информации предоставил я(не знаю что добавить еще!!)? Знающие люди подскажите пожалуйста, очень хочу дипломную на Lotus'е делать, но останавливает такая ерунда.
ps..
посоветовали на другом форуме
Зайди в ACL, добавь Anonymus с правами Author( или Editor)
но таже самая история, ничего не произошло! Странички нету на сервере!
ps. почему в Lotus'е так....я же захожу в Designer под админом, почему режим отладки работает для anonymous
 

NickProstoNick

Статус как статус :)
Lotus team
22.08.2008
1 809
21
#2
1. ACL базы -> пользователя Anonymous лучше удалить
2. ACL базы -> Advanced -> Maximum Internet Name.... должен быть хотябы Reader
3. В дизайнере в твоем проекте (базе) выставь опцию
Project -> Build Automaticaly

А еще вопрос.... у тебя открывается в WEB страница по умолчанию?
 
S

SiM22

#3
NickProstoNick спасибо за поддержку!
1)Удаляю anonymous выходит знакомая ошибка и ничего не открывает вообще.
2)Был editor, поставил Reader.
3)Project -> Build Automaticaly - это установлено и было
по http://localhost(и по названию host'а) открывает дефолтовую черную страницу Lotus Domino с help'ами и с ссылками..
ps. я в шоке проста, через тулзу Domino Admin захожу, а через webadmin.nsf нет..
ps.ps и еще...до установки на win2003 устанавливал все это на Vista! Та же самая история, но.....файл проэкта test.nsf в браузере как бы "видел" а страницу xPage - нет...(я конечно не разбираюсь в Lotus но может это поможет?)
 

NickProstoNick

Статус как статус :)
Lotus team
22.08.2008
1 809
21
#4
Vista тут не при чем. у меня сервер тоже на висте... и проблем нет.
А можно эту твою тестовую базу посмотреть??
 
Статус
Закрыто для дальнейших ответов.