Доработка Счета Фактуры в ТиС

  • Автор темы Karambol
  • Дата начала
K

Karambol

Гость
#1
Добрый день! Подскажите, пожалуйста, какие изменения нужно внести в документ СФ, чтобы поле "к платежно-расчетному документу" заполнялось автоматически? Может быть есть уже готовые решения?
1С 7.7, конф ТиС 9.2
 
K

kaa

Гость
#2
Надо просто заполнить в с/ф поля к платежно-расчетному документу :)
 
K

Karambol

Гость
#3
Надо просто заполнить в с/ф поля к платежно-расчетному документу
Для: kaa
Да, нужно, чтобы это поле заполнялось автоматически. Как это можно реализовать?
 
K

Karambol

Гость
#5
Для: kaa
Я как раз и хочу его получить. :)
Нужно, чтобы при создании СФ была возможность автоматического заполнения поля "К платежно-расч документу".
Можно ли как-то вычислить, какую платежку указывать в этом поле?
 
K

kaa

Гость
#6
Я понимаю так ежели это счет-фактура выданая то в полях должны стоять реквизиты счета а не платежки. А в торговле Счет это Заявка покупателя. При формировании с/ф берем документ основание реализации выкусываем что надо и вставляем :)
 
K

Karambol

Гость
#7
Для: kaa
Может быть я чего-то недопонимаю, но почему тогда в Бухгалтерии у нас бухгалтер в поле "к платежно-расчетному документу" СФ выданной
забивает номер и дату платежного документа из Выписки?
 
K

kaa

Гость
#9
<!--QuoteBegin-Karambol+13:02:2008, 19:54 -->
<span class="vbquote">(Karambol @ 13:02:2008, 19:54 )</span><!--QuoteEBegin-->Может быть я чего-то недопонимаю, но почему тогда в Бухгалтерии у нас бухгалтер в поле "к платежно-расчетному документу" СФ выданной
забивает номер и дату платежного документа из Выписки?
[snapback]97896" rel="nofollow" target="_blank[/snapback]​
[/quote]

Если вводит выписку на основании Реализации, то ПриЗаписи() можно найти нужную фактуру да и проставить !
 
K

Karambol

Гость
#10
Для: kaa
Нет, схема немного другая. Клиент вносит аванс, потом преобретает товар. В СФ нужно получить список документов, с которых этот аванс списывали при реализации.
Т.е., схема такая: аванс->реализация->СФ.

_ДатаИНомерПлатежногоДокумента = "";
Рег=СоздатьОбъект("Регистр.Покупатели");
Если Рег.ВыбратьДвиженияДокумента(ДокОснование)=1 Тогда
Пока Рег.ПолучитьДвижение()=1 Цикл
Если (Рег.КредДокумент.Вид() = "СтрокаВыпискиПриход") И (Рег.Договор = Договор) Тогда
_ДатаИНомерПлатежногоДокумента = _ДатаИНомерПлатежногоДокумента + " , №" + глНомерНаПечать(Рег.КредДокумент) + " от " + Рег.КредДокумент.ДатаДок
КонецЕсли;
КонецЦикла;
КонецЕсли;
_ДатаИНомерПлатежногоДокумента = СокрЛП(Сред(_ДатаИНомерПлатежногоДокумента,3));
;)