Доработка Счета Фактуры в ТиС

Тема в разделе "1C и всё что с ней связано", создана пользователем Karambol, 13 фев 2008.

  1. Karambol

    Karambol Гость

    Добрый день! Подскажите, пожалуйста, какие изменения нужно внести в документ СФ, чтобы поле "к платежно-расчетному документу" заполнялось автоматически? Может быть есть уже готовые решения?
    1С 7.7, конф ТиС 9.2
     
  2. kaa

    kaa Гость

    Надо просто заполнить в с/ф поля к платежно-расчетному документу :)
     
  3. Karambol

    Karambol Гость

    Для: kaa
    Да, нужно, чтобы это поле заполнялось автоматически. Как это можно реализовать?
     
  4. kaa

    kaa Гость

    Алгоритм заполнения объясни
     
  5. Karambol

    Karambol Гость

    Для: kaa
    Я как раз и хочу его получить. :)
    Нужно, чтобы при создании СФ была возможность автоматического заполнения поля "К платежно-расч документу".
    Можно ли как-то вычислить, какую платежку указывать в этом поле?
     
  6. kaa

    kaa Гость

    Я понимаю так ежели это счет-фактура выданая то в полях должны стоять реквизиты счета а не платежки. А в торговле Счет это Заявка покупателя. При формировании с/ф берем документ основание реализации выкусываем что надо и вставляем :)
     
  7. Karambol

    Karambol Гость

    Для: kaa
    Может быть я чего-то недопонимаю, но почему тогда в Бухгалтерии у нас бухгалтер в поле "к платежно-расчетному документу" СФ выданной
    забивает номер и дату платежного документа из Выписки?
     
  8. kaa

    kaa Гость

    Может у буха и спросить :)
     
  9. kaa

    kaa Гость

    <!--QuoteBegin-Karambol+13:02:2008, 19:54 -->
    <span class="vbquote">(Karambol @ 13:02:2008, 19:54 )</span><!--QuoteEBegin-->Может быть я чего-то недопонимаю, но почему тогда в Бухгалтерии у нас бухгалтер в поле "к платежно-расчетному документу" СФ выданной
    забивает номер и дату платежного документа из Выписки?
    [snapback]97896" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Если вводит выписку на основании Реализации, то ПриЗаписи() можно найти нужную фактуру да и проставить !
     
  10. Karambol

    Karambol Гость

    Для: kaa
    Нет, схема немного другая. Клиент вносит аванс, потом преобретает товар. В СФ нужно получить список документов, с которых этот аванс списывали при реализации.
    Т.е., схема такая: аванс->реализация->СФ.

    _ДатаИНомерПлатежногоДокумента = "";
    Рег=СоздатьОбъект("Регистр.Покупатели");
    Если Рег.ВыбратьДвиженияДокумента(ДокОснование)=1 Тогда
    Пока Рег.ПолучитьДвижение()=1 Цикл
    Если (Рег.КредДокумент.Вид() = "СтрокаВыпискиПриход") И (Рег.Договор = Договор) Тогда
    _ДатаИНомерПлатежногоДокумента = _ДатаИНомерПлатежногоДокумента + " , №" + глНомерНаПечать(Рег.КредДокумент) + " от " + Рег.КредДокумент.ДатаДок
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    _ДатаИНомерПлатежногоДокумента = СокрЛП(Сред(_ДатаИНомерПлатежногоДокумента,3));
    ;)
     
Загрузка...

Поделиться этой страницей