Доработка справочника Номенклатура

  • Автор темы Guest
  • Дата начала
G

Guest

#1
По умолчанию, когда встаешь на товар то снизу выбираешь тип цен галочкой и тебе выдается розничная текущая цена...
Необходимо добавить есче1 колонку рядом с колонкой Наименование, например "Цена", в которой бы отражались цены по каждой из позиции... Так проще сравнивать цены в группе товаров... Порыскав в конфигураторе немного запутался... Добавил в Спмравочник.Номеклатура есче 1 реквизит Цена, разместил колонку с ним, но вот где его заполнять...
Подскажите пожалуйста как поступить далее...
Цена товара расчитывается так:
Код:
Цена = УправлениеРозничнойТорговлей.ПолучитьПродажнуюЦену(РабочаяДата, НекаяСсылкаНаТовар, ХарактеристикаНоменклатурыСсылка, ЕдиницаИзмеренияСсылка, Склад);
 
T

TimeDontWait

#2
1 Добавляеш реквизит, тип число , длину и точность выбираеш сам
2 Открываеш форму списка
3 Меню - Вставить - Элемент диалога
4 Открываеш свойства етого реквизита на той же форме списка, и на закладке "Дополнительно" прописываеш формулу, или пишеш процедуру, например "расчитать()" , смотриш снизу есть как минимум две вкладки : Диалог, Модуль... Выбираеш модуль, под процедурами пишеш:
Код:
Процедура Расчитать()
твой код или формула;
или другие вычисления;
КонецПроцедуры
 
G

Guest

#3
ой пардон... не написал для какой версии - 1С УТ 8.1

Но первые 3пункта выполнены элемент размещен в диалоге, только как щас на него повесить мою процедуру, да и как выбрать при расчете номенклатуру напротив которой он стоит.....
 
G

Guest

#4
Ладно по другому задам вопрос: 1C 8.1 УТ В Справочник.Номенклатура.ФормаСписка Имеется табличное поле Список, в котором выводится Назнание, Номер, Артикул и т.д. Вопрос: Как туда правильно добавить поле которое бы отображало, ну например: (Наименование+Порядковый номер)....????
 
T

TimeDontWait

#5
8.1 точно не знаю , но вроде так :
меню - вставить - текст и наводиш на таблицу нажимаеш.
В формуле прописываеш :
СокрЛП(Наименование+Порядковый номер)
 
T

TimeDontWait

#7
Ты прав, но на моей работе, с моими Уважаемыми БУХГАЛТЕРАМИ про такие мелочи часто забываешЬ :KillMe:
 
G

Guest

#8
Ничего не получается( ..... не пойму принцип заполнение таблицы в этом справочнике... HELP!
 
G

Guest

#10
Делаю как в книге Габец/гончарова "Простые примеры разработки".... например добавление для начала отстатка...
1. Создаю реквизит Остаток
2. Размещаю его в списке
3. Списoк->Событие: "Приполученииданных()" и вставляю следующий код:
Код:
	МассивНоменклатуры = Новый Массив;  
Соответствие = Новый Соответствие;

Для Каждого Строка из ОформленияСтрок Цикл	
МассивНоменклатуры.Добавить(Строка.ДанныеСтроки.Ссылка);
Соответствие.Вставить(Строка.ДанныеСтроки.Ссылка, Строка);
КонецЦикла;

Запрос = Новый Запрос("ВЫБРАТЬ
|	ТоварыНаСкладахОстатки.КоличествоОстаток КАК Остаток,
|	ТоварыНаСкладахОстатки.Номенклатура.Ссылка КАК Товар
|ИЗ
|	РегистрНакопления.ТоварыНаСкладах.Остатки( , Номенклатура В (&МассивТоваров)) 
|		КАК ТоварыНаСкладахОстатки");
Запрос.УстановитьПараметр("МассивТоваров", МассивНоменклатуры);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
Соответствие.Получить(Выборка.Товар.Ссылка).Ячейки.Остаток.Значение = Выборка.Остаток;
КонецЦикла;
И хотя остатки есть, однако ничего не заполняется ((((
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#11
Шаолинь,а ты отладчиком пройдись - посмтри выполняется ли вообще этот кусок кода. Если выполняется - есть ли что либо в выборке, и кстати с казать в массиве
 
G

Guest

#12
Все получилось... и отлично работает!!! Правда не без сторонней помощи!!! В списке неправильно разместил первоначально... и переделал процедуру немного по иному....