Доступ НЕ только для чтения к документу из журнала

Тема в разделе "1C и всё что с ней связано", создана пользователем IronGPS, 31 янв 2008.

  1. IronGPS

    IronGPS Гость

    Господа знающие! Столкнулся с такой проблемой:

    Задача:
    Есть журнал документов. Добавляю к нему кнопочку. Хочу чтобы по этой кнопочке менялся атрибут документа, на котором стоит мой выбор.

    Для начала я нашел, что у модуля формы журнала документов есть атрибут " ТекущийДокумент". Его я передаю ф функцию, которая запускается по кнопке. И вроде все хорошо, я могу получить и посмтреть любой атрибут документа, более того, методом УстановитьАтрибут(); я его могу даже поменять (проверял следом - выводил атрибут этого документа), а вот записать документ с измененным атрибутом - не могу! банальный метод Записать(); ругается - говорит :

    ТекДок.Записать();
    {Журнал.ЖурналПоДоставкам.Форма.ФормаСписка.Модуль(6)}: Не выбран документ!

    Это стандартная 7-я конфигурация с небольшими добавлениями, которые делал сам.

    Скидываю код модуля журнала:


    Код (Text):
    Процедура ппп(ТекДок);     
    Сообщить("Текущий:"+ТекДок);  
    Сообщить("Статус до:"+ТекДок.ПолучитьАтрибут("Статус"));
    ТекДок.УстановитьАтрибут("Статус","ДААААА!!!!");
    Сообщить("Статус после:"+ТекДок.ПолучитьАтрибут("Статус"));
    ТекДок.Записать();КонецПроцедуры;

    Это поле "функция" моей кнопки :

    ппп(ТекущийДокумент);




    Далее пробовал так:

    Код (Text):
    Процедура ппп(ТекДок);   
    док = СоздатьОбъект("Документ.НарядНаДоставку");
    док = ТекДок;         
    Сообщить("Текущий:"+док);
    Сообщить("Статус до:"+док.ПолучитьАтрибут("Статус"));
    док.УстановитьАтрибут("Статус","ДААААА!!!!");
    Сообщить("Статус после:"+ТекДок.ПолучитьАтрибут("Статус"));  
    док.Записать();     
    КонецПроцедуры;

    Ошибка та же самая.

    Окно сообщений:

    Текущий:НарядНаДоставку 0000000006 (30.01.08)
    Статус до:Не доставлена
    Статус после:ДААААА!!!!
    док.Записать();
    {Журнал.ЖурналПоДоставкам.Форма.ФормаСписка.Модуль(10)}: Не выбран документ!






    Подскажите как записать изменение?
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    <!--QuoteBegin-IronGPS+31:01:2008, 17:27 -->
    <span class="vbquote">(IronGPS @ 31:01:2008, 17:27 )</span><!--QuoteEBegin-->Процедура ппп(ТекДок);
    док = СоздатьОбъект("Документ.НарядНаДоставку");
    // док = ТекДок;
    док.НайтиДокумент(ТекДок);
    Сообщить("Текущий:"+док);
    Сообщить("Статус до:"+док.ПолучитьАтрибут("Статус"));
    док.УстановитьАтрибут("Статус","ДААААА!!!!");
    Сообщить("Статус после:"+ТекДок.ПолучитьАтрибут("Статус"));
    док.Записать();
    КонецПроцедуры;
    [snapback]96059" rel="nofollow" target="_blank[/snapback]​
    [/quote]
    удачи
     
Загрузка...

Поделиться этой страницей