Древовидный справочник.Выбор группы.

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 22 мар 2005.

Статус темы:
Закрыта.
  1. Гость

    Привет всем.
    У меня возникла проблемма такого характера:
    Есть древовидный справочник "ТерриториальныеОбразования" и справочник "НаселенныеПункты". (см.пример внизу). При ссылке поля "кодТерриториальногоОбразования" в справочнике "НаселенныеПункты" на справочник "ТерриториальныеОбразования" я не могу выбрать группу, могу только элемент.
    Как заставить 1С выбирать группу? Как настроить древовидный справочник таким образом, чтобы можно было создавать только группы.
    Должно быть решение, иначе 1С не язык программирования, а ..... ;).
    Спасибо всем.

    Пример данных в стравочнике "ТерриториальныеОбразования":
    ---------------------
    ТерриториальныеОбразования
    |->(01)Украина
    |...|->(02)Днепропетровская область
    |...|...|->(03)Криворожский район
    |...|->(04)Киевская обл.
    |->(05)Россия
    ---------------------

    Пример данных в стравочнике "НаселенныеПункты":
    |Код |Наименование|кодТерриториальногоОбразования|
    --------------------------------------------------------------------
    |_01_|Кривой Рог___| 02
    |_02_|СиниеКуры___|03
    |_03_|Киев________|01
    --------------------------------------------------------------------
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Может, все же дело не в том, что
    ? Может, "стоит что-то в консерватории подправить?" © М.М.Жванецкий.
    RTFM ЖЖК - это на будущее.
    Но все же отвечу:
    ВыборГруппы(1) в ПриОткрытии() спасет отца русской демократии.
    У элемента при вводе нового пришем: СтатусВозврата(0); Возврат;

    Все же читать документацию полезно. Иначе программисты - это не программисты, а ................... ;)
     
  3. Гость

    Спасибо. Буду копать.
    ЗЫ: Документации с толковым разделением по категориям нет. Лопачу все, что приближается к теме, причем в электронном варианте.
     
  4. Гость

    Вроде разобрался. Выбор группы работает прекрасно, но запрет добавления элементов "криво" получается.
    Для тех, у кого возникнет подобная ситуация, объясню более понятно.
    01. Для разрешения выбора групп выберите из списка справочников нужный. После чего выберите редактирование нужной формы списка. Дальше выбираем закладку "Модуль" и добавляем процедуру(если она еще не создана) и добавляем в нее строчку "ВыборГруппы(1);":
    //
    Процедура ПриОткрытии()
    ВыборГруппы(1);
    КонецПроцедуры
    //
    02. Для запрета добавления в справочник элементов, которые не являются группой добавьте в тот же модуль:
    //
    Процедура ПриЗаписи()
    Если ЭтоГруппа()=0 Тогда
    СтатусВозврата(0); Возврат;
    КонецЕсли
    КонецПроцедуры
    //
    Правда, при такой реализации просто нельзя записать в справочник НеГруппу, но диалог добавления элемента все равно остается. А жаль.
    Пробовал встроить распознавание в "Процедура ПриВводеСтроки()", но на этом этапе еще не известно, что мы добавляем в справочник: элемент или группу.
    PS: Скорее всего можно использовать "Процедура ВводНового(<?>,)", но для этого прийдется вносить данные через документ. А мне этого не хочется, да и задача состояла в том, чтобы на уровне справочника запретить добавление элементов.
     
  5. Гость

    Есть справка в конфигураторе. Там ВСЕ написано, однако....
     
  6. lara

    lara Гость

    Есть ишшо такая весч как Уровень(), можно запретить так
    Если ТекущийЭлемент().Уровень()<4 Тогда
    СтатусВозврата(0);
    и т.п.
    И пиши себе на здоровье элементы тока пятого уровня. А в корне до 4 не создашь
     
  7. pavlo

    pavlo New Member

    Регистрация:
    22 окт 2006
    Сообщения:
    1
    Симпатии:
    0
    нужно уточнить, что если из другой формы списка подбираете скажем номенклатуру, то в списке форм номенклатуры именно нужно ставить это, а не в списке форм вашего конкретного справочника куда подбираете ее :)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей