Двойные Проводки

Тема в разделе "1C и всё что с ней связано", создана пользователем Irisha, 1 авг 2012.

  1. Irisha

    Irisha Гость

    Здравствуйте! Есть простой документ в 1сv8.2 с табличной частью. В ОбработкеПроведения цикл по строкам и одна проводка на каждую строку ТЧ. При нажатии на ОК в документе формируются проводки - далее вопрос: "Данные были изменены. Сохранить изменения?" - и при ответе "да" снова формируются проводки, а при ответе "нет" документ без проводок вообще... С чем это может быть связано? Спасибо..
     
  2. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Конфа самописная? Посморти свойства документа "Удаление движений", что там выставленно? Выложите модуль проведения документа.
     
  3. Irisha

    Irisha Гость

    Да, самописная. В свойстве удаление движений стоит " Удалять автоматически при отмене проведения".
    Модуль
    Код ( (Unknown Language)):
     Процедура ОбработкаПроведения(Отказ, Режим)

    Для Каждого ТекСтрока Из Платежи Цикл
    Если ТекСтрока.Сумма<>0 Тогда
    Движение = Движения.Хозрасчетный.Добавить();
    Движение.СчетКт = ПланыСчетов.Хозрасчетный.АрендаРасчетыСПокупателямиИЗаказчиками;
    Движение.Период = Дата;
    Движение.СчетДт = ТекСтрока.СчетД*цензура*;
    Движение.Сумма = ТекСтрока.Сумма;
    Движение.СубконтоКт.ДоговораАренды = ТекСтрока.Договор;
    Движение.СубконтоКт.Организации = ТекСтрока.Организация;
    Движение.СубконтоКт.СтруктурныеПодразделения = ТекСтрока.Договор.СтруктурноеПодразделение;
    Движение.Содержание = "Оплата от " + ТекСтрока.Организация;
    Движение.Организация = ТекСтрока.Организация;
    КонецЕсли;              
    КонецЦикла;  
    КонецПроцедуры
     
  4. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Хз в чем может быть проблема. Отладчиком не смотрели что приводит к изменению формы? Как вариант можете попробывать следущее (не факт что это будет правильным решением проблеммы).
    Установите свойство "Записывать движения при проведении" в "записывть выбранные"
    Далее ваш модуль измените на

    Код ( (Unknown Language)):
    Процедура ОбработкаПроведения(Отказ, Режим)
    Движения.Хозрасчетный.Записывать = Истина;
    Движения.Записать();
    Движения.Хозрасчетный.Записывать = Истина;
    Для Каждого ТекСтрока Из Платежи Цикл
    Если ТекСтрока.Сумма<>0 Тогда
    .....//Ваш код
    КонецЕсли;              
    КонецЦикла;  
    КонецПроцедуры
     
  5. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Может подписка какая есть.
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Или в ПриЗаписи() еще может что?
     
  7. Irisha

    Irisha Гость

    Всем огромное спасибо. свойство "Записывать движения при проведении" и было в положении "записывть выбранные", помогла установка этого свойства в положение "записывать модифицированные".
     
Загрузка...

Поделиться этой страницей