Это не форма!

  • Автор темы LIGHT
  • Дата начала
L

LIGHT

Гость
#1
Ребята, возникла не приятная ситуация у одного знакомого программиста из глубинки, у которого кроме телефона не чего для связи с коллегами нет.

В общем нужно выручать человека, попробую взять на себя роль сломанного телефона :(

И так:

В дизайнере есть фодформа, которая успешно работала и фунциклировала.
В эту подформу потребовалось добавить 1 поле. Поле было добавлено и комп подвис (не знаю на одном ли сервере ком и клиент). В общем после ребута, при попытке открыть эту пдформу в дизайне вылетает ошибка - "Это не форма", попытка скопировать ее дает тот же результат, подформа не копируется.

Что это и как это лечить, я х.з. Может кто подскажет как помочь человеку.

Спасибо тем кто откликниться.
 

Omh

Well-Known Member
Lotus team
04.07.2007
2 210
1
37
Латвиджа, Рига
#2
Встречалось.
На англицком ошибка звучит как "Not a Form".
Как именно лечить не знаю, обычно вытаскивал из бекапа.

Быстренько полистал IBM форум.
Похоже решения нет, пусть поднимает бекап.
 

Akupaka

А че я?.. О.о
04.10.2007
3 360
2
34
Kiev, Ukraine
#3
ну, попробуй какой-нить фиксап, компакт с параметрами лечения...
сделать копию базы, или реплику, и глянуть будет ли в ней работать...
 

Constantin A Chervonenko

Well-Known Member
Lotus team
#5
ну, попробуй какой-нить фиксап, компакт с параметрами лечения...
сделать копию базы, или реплику, и глянуть будет ли в ней работать...
ФиксАп "чинит" базу путем удаления дефектного док-та без окурка. Т.е. в надежде, что он восстановится из соседней реплики