Фильтр журнала документов

  • Автор темы Tiolan
  • Дата начала
Статус
Закрыто для дальнейших ответов.
T

Tiolan

#1
1с7.
Возможно ли не отображать проведенные документы в журнале? вообще фильтровать журнал по тому проведен ли документ?

В идеале нужен отдельный журнал, в котором отображаются только не проведенные документы определенного вида.

По поиску по форуму ничего помогшего, к сожалению, не нашел. :( Буду очень благодарен за советы.
 
J

jcnby

#2
Процедура ПередПроведением()
Доки=СоздатьОбъект("Документ");
Плохо=0;
Для Сч = 1 По СписокДоков.РазмерСписка() Цикл
Если Доки.НайтиДокумент(СписокДоков.ПолучитьЗначение(Сч))=1 Тогда
Если Доки.Проведен()=0 Тогда
Если Доки.Провести()=0 Тогда
Если Плохо=0 Тогда
ОчиститьОкноСообщений();
КонецЕсли;
Сообщить("Документ "+Доки.Вид()+" номер "+Доки.НомерДок+" остался непроведенным!",6);
Плохо=1;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Плохо=0;


Ет я хаотично вырвал из модуля.... по моему ( а ет очень не доставерные данные) - при непроведенном документе, где выполняется "0" - приписать справочник ..... :( ))) проверить не смог - ибо уже конгец каб дня(( выгоняють....
 
B

b00tch

#3
с 0тборами в жур. доков у 77 пл0хо...
как вариантЪ - обработка с ТабЗначений на форме, в которую 3агоняюцц0 доки 3апросом... любые отборы и с0ртировки... единственный нед0статок (а, с другой стороны - достоинств0... хехе) - список нединамический, надо обновлять принудительн0...
 

Zab

Well-known member
07.08.2006
583
0
#4
Можно. Правда, как всегда ч-з ... Добавляем в документ специальный реквизит, который дублирует состояние документа "проведен не проведен" И ставим по нему фильтр... Не поняимаю в чем возникли затруднения?
 
T

Tiolan

#5
Спасибо за отзывы)

Затруднения как раз в том, что список должен быть динамическим (параллельная работа юзверей) плюс работать без тормозов. сейчас все настроено как описано у b00tch.

при непроведенном документе, где выполняется "0" - приписать справочник
это как? не догоняю :)
 

Zab

Well-known member
07.08.2006
583
0
#6
Помедитируй над методом журнала документов
Код:
[b]УстановитьОтбор(<?>,);[/b]
SetSelection(<?>,);
Синтаксис:
УстановитьОтбор(<ИмяОтбора>,<ЗначениеОтбора>)
Назначение:
Установить отбор журнала.
Параметры: 
<ИмяОтбора> - строка с именем отбора (если пусто - отбор отключается);
<ЗначениеОтбора> - значение отбора.
что еще непонятно?
 
Статус
Закрыто для дальнейших ответов.