Фильтр журнала документов

Тема в разделе "1C и всё что с ней связано", создана пользователем Tiolan, 20 июл 2007.

Статус темы:
Закрыта.
  1. Tiolan

    Tiolan Гость

    1с7.
    Возможно ли не отображать проведенные документы в журнале? вообще фильтровать журнал по тому проведен ли документ?

    В идеале нужен отдельный журнал, в котором отображаются только не проведенные документы определенного вида.

    По поиску по форуму ничего помогшего, к сожалению, не нашел. :( Буду очень благодарен за советы.
     
  2. jcnby

    jcnby Гость

    Процедура ПередПроведением()
    Доки=СоздатьОбъект("Документ");
    Плохо=0;
    Для Сч = 1 По СписокДоков.РазмерСписка() Цикл
    Если Доки.НайтиДокумент(СписокДоков.ПолучитьЗначение(Сч))=1 Тогда
    Если Доки.Проведен()=0 Тогда
    Если Доки.Провести()=0 Тогда
    Если Плохо=0 Тогда
    ОчиститьОкноСообщений();
    КонецЕсли;
    Сообщить("Документ "+Доки.Вид()+" номер "+Доки.НомерДок+" остался непроведенным!",6);
    Плохо=1;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    Плохо=0;


    Ет я хаотично вырвал из модуля.... по моему ( а ет очень не доставерные данные) - при непроведенном документе, где выполняется "0" - приписать справочник ..... :( ))) проверить не смог - ибо уже конгец каб дня(( выгоняють....
     
  3. b00tch

    b00tch Гость

    с 0тборами в жур. доков у 77 пл0хо...
    как вариантЪ - обработка с ТабЗначений на форме, в которую 3агоняюцц0 доки 3апросом... любые отборы и с0ртировки... единственный нед0статок (а, с другой стороны - достоинств0... хехе) - список нединамический, надо обновлять принудительн0...
     
  4. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Можно. Правда, как всегда ч-з ... Добавляем в документ специальный реквизит, который дублирует состояние документа "проведен не проведен" И ставим по нему фильтр... Не поняимаю в чем возникли затруднения?
     
  5. Tiolan

    Tiolan Гость

    Спасибо за отзывы)

    Затруднения как раз в том, что список должен быть динамическим (параллельная работа юзверей) плюс работать без тормозов. сейчас все настроено как описано у b00tch.

    это как? не догоняю :)
     
  6. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Помедитируй над методом журнала документов
    Код (Text):
    [b]УстановитьОтбор(<?>,);[/b]
    SetSelection(<?>,);
    Синтаксис:
    УстановитьОтбор(<ИмяОтбора>,<ЗначениеОтбора>)
    Назначение:
    Установить отбор журнала.
    Параметры:
    <ИмяОтбора> - строка с именем отбора (если пусто - отбор отключается);
    <ЗначениеОтбора> - значение отбора.
    что еще непонятно?
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей