Формат Числа

Дайнеко

Well-Known Member
19.11.2009
951
0
#1
- Есть таблица в режиме ввода данных.
- В ней есть ячейка для ввода. Установлен формат: Числовая, и формат "Ч017.3. " Параметр "Контроль" = Красный
- Человек вносит данные, программа их пересчитывает, затем распечатывает.

Проблема: норматив требует отрицательное число писать к скобочках. Например: (123) обозначает -123
(Однако, дебильно - Да?)
Кто подскажет, есть такой формат?

Заранее отметаю ответы "преобразуй в строку". Жду подсказки.
 

Дайнеко

Well-Known Member
19.11.2009
951
0
#3
А как в формах от 1С сделано? Баланс, например.
Спасибо, совет мудрый. Главное, не для ленивых. ;)


Да фиг его знает, как в типовой!
- У меня такой нет под руками. В найденной мною форме это простой отчет.
- А может у россиян и нет такого требования.
 

unknown181538

НеГуру
28.12.2008
1 417
0
#4
Российский баланс:

Код:
Если ЗначениеЯчейки <> 0 Тогда
Если ЗначениеЯчейки < 0 Тогда
ВыводитьВСкобках=1;
ТекстЯчейкиВПечатнойФорме = СтрЗаменить(ТекстЯчейкиВПечатнойФорме, "-","");
КонецЕсли;
Если ВыводитьВСкобках=1 Тогда
ПечатнаяФорма.Область(ИмяЯчейки).Текст="("+ТекстЯчейкиВПечатнойФорме+")";
КонецЕсли;
КонецЕсли;
 

Дайнеко

Well-Known Member
19.11.2009
951
0
#5
Спасибо. В 8-ке я так и сделаю.
А мне-ж надо как-то в 7-ке поменять
 

Дайнеко

Well-Known Member
19.11.2009
951
0
#7
а это и есть прогамма на семерке.
Спасибо. Чей-то не заметил, что и у 7-ки есть такой атрибут. Но у меня ничего не получилось. Команда:
Таблица.Область("Доход").Текст="(100)";
сбрасывает значение ячейки в " ".
Ведь тип данных моей ячейки числовой. Вот, к примеру:
Таблица.Область("Доход").Текст="-100";
работает.

Придется поискать баланс от типовой. Наверное ячейке присваивают тип Строка.