Формат Числа

Тема в разделе "1C и всё что с ней связано", создана пользователем Дайнеко, 10 апр 2013.

  1. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    - Есть таблица в режиме ввода данных.
    - В ней есть ячейка для ввода. Установлен формат: Числовая, и формат "Ч017.3. " Параметр "Контроль" = Красный
    - Человек вносит данные, программа их пересчитывает, затем распечатывает.

    Проблема: норматив требует отрицательное число писать к скобочках. Например: (123) обозначает -123
    (Однако, дебильно - Да?)
    Кто подскажет, есть такой формат?

    Заранее отметаю ответы "преобразуй в строку". Жду подсказки.
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    А как в формах от 1С сделано? Баланс, например.
     
  3. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Спасибо, совет мудрый. Главное, не для ленивых. ;)


    Да фиг его знает, как в типовой!
    - У меня такой нет под руками. В найденной мною форме это простой отчет.
    - А может у россиян и нет такого требования.
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Российский баланс:

    Код ( (Unknown Language)):
    Если ЗначениеЯчейки <> 0 Тогда
    Если ЗначениеЯчейки < 0 Тогда
    ВыводитьВСкобках=1;
    ТекстЯчейкиВПечатнойФорме = СтрЗаменить(ТекстЯчейкиВПечатнойФорме, "-","");
    КонецЕсли;
    Если ВыводитьВСкобках=1 Тогда
    ПечатнаяФорма.Область(ИмяЯчейки).Текст="("+ТекстЯчейкиВПечатнойФорме+")";
    КонецЕсли;
    КонецЕсли;
     
  5. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Спасибо. В 8-ке я так и сделаю.
    А мне-ж надо как-то в 7-ке поменять
     
  6. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    а это и есть прогамма на семерке.
     
  7. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Спасибо. Чей-то не заметил, что и у 7-ки есть такой атрибут. Но у меня ничего не получилось. Команда:
    Таблица.Область("Доход").Текст="(100)";
    сбрасывает значение ячейки в " ".
    Ведь тип данных моей ячейки числовой. Вот, к примеру:
    Таблица.Область("Доход").Текст="-100";
    работает.

    Придется поискать баланс от типовой. Наверное ячейке присваивают тип Строка.
     
Загрузка...

Поделиться этой страницей