Групповая обработка справочника

Тема в разделе "1C и всё что с ней связано", создана пользователем Kiddy, 4 мар 2009.

  1. Kiddy

    Kiddy Гость

    Доброе время суток. Народ нужна консультация - помощь.
    Формирую Список скидок по всем клиентам из таблицы скидок

    Текстзапроса="
    |ТоварнаяГруппа=Справочник.СкидкиКлиента.ТоварнаяГруппа;
    |Группировка ТоварнаяГруппа Упорядочить По ТоварнаяГруппа.Наименование;
    |";

    Запрос=СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(Текстзапроса)=0 Тогда
    возврат;
    КонецЕсли;

    Запрос.ВНачалоВыборки();
    НомерСтроки=1;
    Пока Запрос.Группировка("ТоварнаяГруппа")>0 Цикл
    Если Запрос.ТоварнаяГруппа.Выбран()=1 Тогда
    ТаблицаСкидок.НоваяСтрока(НомерСтроки);
    ТаблицаСкидок.ПолучитьСтрокуПоНомеру(НомерСтроки);
    ТаблицаСкидок.Номенклатура=Запрос.ТоварнаяГруппа.Наименование;
    НомерСтроки=НомерСтроки+1;
    КонецЕсли;
    КонецЦикла;

    Результат отработаного запроса впечатляет
    Есть повторяющиеся сточки !!!!!!!! и не отсортировано !!!!

    Я так понимаю проблема в запросе, или....

    Буду очень благодарен за совет и помощь
    Валера
     

    Вложения:

    • __________.bmp
      Размер файла:
      612,2 КБ
      Просмотров:
      12
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    у тебя идет группировка по элементам, а не по наименованию. По наименованию выглядит так
    Текстзапроса="
    |ТоварнаяГруппа=Справочник.СкидкиКлиента.ТоварнаяГруппа.Наименование;
    |Группировка ТоварнаяГруппа Упорядочить По ТоварнаяГруппа;
    |";

    А ещё проще
    Текстзапроса="
    |Без итогов;
    |Номенклатура=Справочник.СкидкиКлиента.ТоварнаяГруппа.Наименование;
    |Группировка Номенклатура;
    |";
    Запрос=СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(Текстзапроса)=0 Тогда
    возврат;
    КонецЕсли;

    Запрос.Выгрузить(ТаблицаСкидок);
    ТаблицаСкидок.Свернуть(Номенклатура);// сворачиваешь по имени
    ТаблицаСкидок.Сортировать("+Номенклатура");// сортируешь

    а потом добавляешь новые колонки и заполняешь как надо. Можно и скидки запросом вытащить ( если они забиты)
     
  3. Kiddy

    Kiddy Гость

    puh14 , сенкс за помощь. Запрос заработал. Правильно. Счас похимичу с отображением колонок и полный порядок.
    Есчё раз, большое спасибо.
     
Загрузка...

Поделиться этой страницей