И снова про корейскую кодировку

PaKo

Well-known member
29.04.2005
59
0
#1
Наверное всем известно, что если скриптом создавать письмо в mailbox со ссылкой на документ, то оно приходит в корейской кодировке.

Я снова наткнулся на эти грабли. Написал класс в котором 3 метода.
1-й создает документ письма
2-й наполняет его (точнее)
3-й отправляет письмо одному получателям.

Реализована отправка через создание документа в mailbox. В итоге если есть doclink то письмо приходит в корейской кодировке.

Решил я побороть это как нибудь. Создал на форме простое действие, подключил библиотеку рассылки и начал экспериментировать с содержимым письма. Локализовал причину - ссылка. Далее попробовал тупо создать такое же письмо но без класса.

Взял все 3 мои метода и по порядку запихнул в действие проверки. Как не мучился не мог получить корейскую кодировку. Письма приходят в нужном формате.

Письма приходит похожи 1 в 1. Все запускается на стороне клиента, но если через библиотеку и класс то получаем корейца, если тупо скриптом - то все нормально.

Разумного объяснение феномена не вижу. Может кто сталкивался с похожей проблемой и уже победил её?
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 598
275
#2
тут явные противоречия в изложени:
Взял все 3 мои метода и по порядку запихнул в действие проверки. Как не мучился не мог получить корейскую кодировку. Письма приходят в нужном формате.
Письма приходит похожи 1 в 1. Все запускается на стороне клиента, но если через библиотеку и класс то получаем корейца, если тупо скриптом - то все нормально.
 

alik86

Lotus team
20.11.2008
465
1
#3
Оффтоп: Долой библиотеки и классы, даёшь весь код на кнопках! :)
 

lmike

нет, пердело совершенство
Lotus team
27.08.2008
6 598
275
#4
код в судию
ежелиб глобальная видимость к-л переменных - могут быть траблы, а так - LS он и есть LS