Инвинтаризация НФА в бюджетной конфигурации

Тема в разделе "1C и всё что с ней связано", создана пользователем zemleroy, 22 ноя 2007.

Статус темы:
Закрыта.
  1. zemleroy

    zemleroy Гость

    Господа программисты помогите пожайлуста решить такую проблемку: существует такой отчётик Инвин. НФА , который формирует данные по НФА находящимся на определённом МОЛе. А теперь вопрос: подскажите алгоритм при котором я смогла бы выбрать определённую группу номенклатуры (например, на сотруднике несколько служб(группы номенклатуры):ГСМ, з/ч) чтобы именно по ней и по МОЛу формировался отчёт? а то формирует по всей номенклатуре сразу. (((Заранее спасибо
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    алгоритм:
    1. получить НФА
    2. проверить принадлежность к выбранной группе
    3. если не принадлежит, перейти на п. 5
    4. вывести НФА в отчет
    5. если НФА не последний, перейти к п.1
     
  3. zemleroy

    zemleroy Гость

    НаименованиеП=глПолноеНаименование(ВыбНФА);
    Если выбНФА.Принадлежит(Номенклатура)=0 тогда
    продолжить;
    КонецЕсли;
    не получилося(((((( пишет поле агр. не обнаружено((((( ZAB помоги!
     
  4. zemleroy

    zemleroy Гость

    НаименованиеП=глПолноеНаименование(ВыбНФА);
    Если грНоменклатура. Выбран()=1 тогда
    Если выбНФА.ПринадлежитГруппе (ГрНоменклатура)=1 тогда
    иначе продолжить;
    КонецЕсли;
    КонецЕсли;
    СДЕЛАЛА!!!!!!!!!!!! :rolleyes: :D :D :D
     
  5. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Класс. Умница, поздравляю :rolleyes:
     
  6. zemleroy

    zemleroy Гость

    Для: Zab
    подскажите пж как сделать тоже самое только с ОС? по элементам выбирает а по группе нет(((
     
  7. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Если группа ОС-это группа справочника, а не реквизит, то должен работать вышеприведенный код. Или может влияет вид подчиненности справочнка? Может у тебя в ОС подчинение элементу?
     
  8. zemleroy

    zemleroy Гость

    ОС подчинен справочнику фирмы(( если убрать принадлежность то всё идёт! номенклатура ни к чему ни прикреплена поэтому и пошла)))
     
  9. zemleroy

    zemleroy Гость

    закройте тему! я сделала! :)
     
  10. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Тема закрыта по просьбе дамы.
     
Загрузка...
Похожие Темы - Инвинтаризация НФА бюджетной
  1. alturgrey
    Ответов:
    1
    Просмотров:
    1.145
  2. lekhaplaton
    Ответов:
    3
    Просмотров:
    2.113
  3. fedotxxl
    Ответов:
    1
    Просмотров:
    2.138
Статус темы:
Закрыта.

Поделиться этой страницей