Итератор для значения не определен

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 7 окт 2009.

  1. SeverBap

    SeverBap Well-Known Member

    Регистрация:
    18 сен 2007
    Сообщения:
    440
    Симпатии:
    0
    Ситуация такая: имеется документ с реквизитом типа Хранилище значений, у документа нет табличной части. как я понял она хранится в хранилищезначений. В основной форме сделано очень просто все значения вбиваются в таблицу значений потом призаписи копирутся сначало в хранилищезначений срабатывает обработка проведения и там делается обход по строкам
    прмерно так
    Код (Text):
        ВыборкаПоЗапросу = ВыборкаДляСозданияДвижений.Получить();
    Для Каждого Строка Из ВыборкаПоЗапросу Цикл
    Движение = Движения.ЦеныПродажи.Добавить();
    Движение.Период = Дата;
    Движение.Регистратор = Ссылка;
    Движение.Номенклатура = Строка.Номенклатура;
    Движение.ДопИзмерение = Строка.ДопИзмерение;
    Движение.Единица  = Строка.Единица;
    Движение.КатегорияЦен = Строка.КатегорияЦен;
    Движение.Цена        = Строка.Цена;
    КонецЦикла;
    далее повторно делается запись движений:
    Код (Text):
        Для каждого ТипДвижения Из Движения Цикл
    ТипДвижения.Записать();
    КонецЦикла;
    тоесть все нормально!
    я написал обработку по исправлению значений (в документе редактировать записи заприщено написал внешнюю обработку)
    с таким кодом при записи:
    Код (Text):
        Если Не глЗначениеНеЗаполнено(ДокументРедактирования) Тогда
    ДокументОбработки=ДокументРедактирования.ПолучитьОбъект();
    ВыборкаПоЗапросу = ДокументОбработки.ВыборкаДляСозданияДвижений.Получить().Скопировать();
    ДокументОбработки.ВыборкаДляСозданияДвижений=ТЗ.Скопировать();
    ДокументОбработки.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
    и пишит Итератор для значения не определен!!!!
    как решить эту проблему??
     
  2. DjAlex

    DjAlex Гость

    А не пробовали через:
    ДокументОбработки.ВыборкаДляСозданияДвижений = Новый ХранилищеЗначения(ТЗ);
     
Загрузка...

Поделиться этой страницей