Итератор для значения не определен

SeverBap

Well-known member
18.09.2007
451
0
#1
Ситуация такая: имеется документ с реквизитом типа Хранилище значений, у документа нет табличной части. как я понял она хранится в хранилищезначений. В основной форме сделано очень просто все значения вбиваются в таблицу значений потом призаписи копирутся сначало в хранилищезначений срабатывает обработка проведения и там делается обход по строкам
прмерно так
Код:
	ВыборкаПоЗапросу = ВыборкаДляСозданияДвижений.Получить();
Для Каждого Строка Из ВыборкаПоЗапросу Цикл 
Движение = Движения.ЦеныПродажи.Добавить();
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Номенклатура = Строка.Номенклатура;
Движение.ДопИзмерение = Строка.ДопИзмерение;
Движение.Единица	 = Строка.Единица;
Движение.КатегорияЦен = Строка.КатегорияЦен;
Движение.Цена 		 = Строка.Цена;
КонецЦикла;
далее повторно делается запись движений:
Код:
	Для каждого ТипДвижения Из Движения Цикл
ТипДвижения.Записать();
КонецЦикла;
тоесть все нормально!
я написал обработку по исправлению значений (в документе редактировать записи заприщено написал внешнюю обработку)
с таким кодом при записи:
Код:
	Если Не глЗначениеНеЗаполнено(ДокументРедактирования) Тогда
ДокументОбработки=ДокументРедактирования.ПолучитьОбъект();
ВыборкаПоЗапросу = ДокументОбработки.ВыборкаДляСозданияДвижений.Получить().Скопировать();
ДокументОбработки.ВыборкаДляСозданияДвижений=ТЗ.Скопировать();
ДокументОбработки.Записать(РежимЗаписиДокумента.Проведение);
КонецЕсли;
и пишит Итератор для значения не определен!!!!
как решить эту проблему??
 
D

DjAlex

#2
А не пробовали через:
ДокументОбработки.ВыборкаДляСозданияДвижений = Новый ХранилищеЗначения(ТЗ);