Изменение представления субконто

Тема в разделе "1C и всё что с ней связано", создана пользователем Elle, 24 ноя 2010.

  1. Elle

    Elle Гость

    Вот в чем вопрос, есть субконто Договора с типом значений Документ, как мне в стандартных отчетах подменять представление этого субконто в зависимости если этодокумент например Контракт, чтобы выводилось не только вид документа, номер и дата, а еще и дополнительный реквизит.
    Может создать функцию где проверю вид субконто, потом как проверить тип субконто? и как именно Правильно назначить ПредставлениеСубконто()?
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Указываем версию платформы.
     
  3. Elle

    Elle Гость

    7.7 :) забыла
    Необходимо такого типа функцию, но, чтобы функция была универсальной к стандартным бухотчетам, подставлялась и к субконто 2, 3. Эти стандартные отчети сложные для меня, не очень понятна их структура и навороты.
    Код (Text):
    Функция ПредставлениеСубконто()
    Если (Ит.Субконто().Вид()="Договор") Или (Ит.Субконто().Вид()="Контракт") Тогда
    Возврат Ит.ПредставлениеСубконто()=Ит.ПредставлениеСубконто()+" "+Ит.Субконто().НомерДоговора;
    Иначе
    Возврат Ит.ПредставлениеСубконто();
    КонецЕсли;
    КонецФункции
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Код ( (Unknown Language)):
    Функция ПредставлениеСубконто(ВхСубконто,ВхПредставление)
    Если (ВхСубконто.Вид()="Договор") Или (ВхСубконто.Вид()="Контракт") Тогда
    Возврат ВхСубконто=ВхПредставление+" "+ВхСубконто.НомерДоговора;
    Иначе
    Возврат ВхПредставление;
    КонецЕсли;
    КонецФункции

    Ну, например ОСВ по счету....
    В секциях 2,5, и 9 меняем содержимое ячеек
    Для Секции2: вместо "Ит.ПредставлениеСубконто(2)" - "ПредставлениеСубконто(Ит.Субконто(2),Ит.ПредставлениеСубконто(2))"
     
  5. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Ага (это я unknown181538). И я так сделал. Но столкнуля с тем, что не везде можно воткнуть методику. А только там, где выводится субконто обособлено: ОСВ по счету, анализ и карточка субконто. А вот генеральный отчет Карточка счета выводит Представление проводки. А это слитная строка с кучей всех субконто проводки + примечание. Ничего не мог поделать.
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Меня вообще слегка удручают всегда задачи подобного рода :welcome:
     
  7. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Ибо, следует отметить, что бухгалтерские отчеты сделаны не слишком здорово.
    Что мешало сделать реквизит на форме, который бы управлял представлением субконто на усмотрение пользователя ?
    Опять 8-я буква алфавита не может спрятать своих волосатых ушей :)
     
  8. Elle

    Elle Гость

    Значить так вот работает:
    В глобальнику функцию навояла, и в нужных отчетах использую
    Код (Text):
    Функция глПредставлениеСубконто(ВхСубконто,ВхПредставление) Экспорт
    Если (ВхСубконто.Вид()="Договор") Или (ВхСубконто.Вид()="Контракт") Тогда
    ВхСубконто = ВхПредставление+" "+ВхСубконто.НомерДоговора;
    Возврат ВхСубконто;
    Иначе
    Возврат ВхПредставление;
    КонецЕсли;
    КонецФункции
    Поняла из обсуждения что в отчет карточка субконто функция не будет работать. Тоесть в ПредставлениеПроводки() никак нужное представление неподменить?
     
  9. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Не смотрел что там, но я разрешаю) Т.е. как-то наверняка можно)
     
  10. Elle

    Elle Гость

    :) спасибо за разрешение))))
     
Загрузка...

Поделиться этой страницей