Изменение представления субконто

  • Автор темы Elle
  • Дата начала
E

Elle

#1
Вот в чем вопрос, есть субконто Договора с типом значений Документ, как мне в стандартных отчетах подменять представление этого субконто в зависимости если этодокумент например Контракт, чтобы выводилось не только вид документа, номер и дата, а еще и дополнительный реквизит.
Может создать функцию где проверю вид субконто, потом как проверить тип субконто? и как именно Правильно назначить ПредставлениеСубконто()?
 
E

Elle

#3
7.7 :) забыла
Необходимо такого типа функцию, но, чтобы функция была универсальной к стандартным бухотчетам, подставлялась и к субконто 2, 3. Эти стандартные отчети сложные для меня, не очень понятна их структура и навороты.
Код:
Функция ПредставлениеСубконто()
Если (Ит.Субконто().Вид()="Договор") Или (Ит.Субконто().Вид()="Контракт") Тогда
Возврат Ит.ПредставлениеСубконто()=Ит.ПредставлениеСубконто()+" "+Ит.Субконто().НомерДоговора;
Иначе 
Возврат Ит.ПредставлениеСубконто();
КонецЕсли;
КонецФункции
 

unknown181538

НеГуру
28.12.2008
1 417
0
#4
Код:
Функция ПредставлениеСубконто(ВхСубконто,ВхПредставление)
Если (ВхСубконто.Вид()="Договор") Или (ВхСубконто.Вид()="Контракт") Тогда
Возврат ВхСубконто=ВхПредставление+" "+ВхСубконто.НомерДоговора;
Иначе 
Возврат ВхПредставление;
КонецЕсли;
КонецФункции

Ну, например ОСВ по счету....
В секциях 2,5, и 9 меняем содержимое ячеек
Для Секции2: вместо "Ит.ПредставлениеСубконто(2)" - "ПредставлениеСубконто(Ит.Субконто(2),Ит.ПредставлениеСубконто(2))"
 

Дайнеко

Well-known member
19.11.2009
951
0
#5
Ага (это я unknown181538). И я так сделал. Но столкнуля с тем, что не везде можно воткнуть методику. А только там, где выводится субконто обособлено: ОСВ по счету, анализ и карточка субконто. А вот генеральный отчет Карточка счета выводит Представление проводки. А это слитная строка с кучей всех субконто проводки + примечание. Ничего не мог поделать.
 

vbs

Well-known member
18.02.2007
1 708
1
#7
Ибо, следует отметить, что бухгалтерские отчеты сделаны не слишком здорово.
Что мешало сделать реквизит на форме, который бы управлял представлением субконто на усмотрение пользователя ?
Опять 8-я буква алфавита не может спрятать своих волосатых ушей :)
 
E

Elle

#8
Значить так вот работает:
В глобальнику функцию навояла, и в нужных отчетах использую
Код:
Функция глПредставлениеСубконто(ВхСубконто,ВхПредставление) Экспорт
Если (ВхСубконто.Вид()="Договор") Или (ВхСубконто.Вид()="Контракт") Тогда
ВхСубконто = ВхПредставление+" "+ВхСубконто.НомерДоговора;
Возврат ВхСубконто;
Иначе 
Возврат ВхПредставление;
КонецЕсли;
КонецФункции
Поняла из обсуждения что в отчет карточка субконто функция не будет работать. Тоесть в ПредставлениеПроводки() никак нужное представление неподменить?