изменения счет-фактуры

Тема в разделе "1C и всё что с ней связано", создана пользователем yullevick, 25 июн 2009.

  1. yullevick

    yullevick Гость

    Просмотрела форум, но не нашла обсеждения последних изменений по сч.-ф.
    Что нужно изменить в программе 1С:Бухгалтерия 7,7 (Обычная), чтобы в стр.2 счет-фактур появилось полное и сокращенное название предприятия?
    Пробовала менять константы, но тогда изменяется название предприятия и в п/поручениях, а банк не принимает двойного написания предприятия.
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    а где именно это нужно - в печатной форме или же в диалоговом окне?
     
  3. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Если нет релиза 507, тогда
    В таблице поставь выражение "Продавец", а в процедуре Печать()
    текст
    Если ДатаДок < '09.06.2009' Тогда
    Продавец = СокрЛП(Константа.НазваниеОрганизации);
    Иначе
    Продавец = СокрЛП(Константа.ОфициальноеНазваниеОрганизации) + " (" + СокрЛП(Константа.НазваниеОрганизации) + ")";
    КонецЕсли;



    Когда меняешь константу "НазваниеОрганизации"
    отвечай "нет" на вопрос об изменении Полного наименования - это Константа.ОфициальноеНазваниеОрганизации
     
  4. yullevick

    yullevick Гость

    Дорогой Мегаруру!
    Я совсем не программист (правда раньше по подобным ответам у меня получалось менять программы), но в этот раз что-то не выходит. Не могли бы Вы подсказать по другому? Очень на Вас надеюсь и жду ответа!
    С уважением, Юлия.
     
  5. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    А что конкретно не выходит ?
    В таблице СФ283 есть ячейка со свойством "шаблон", в старой форме ее содержимое выглядит так :
    Продавец : [Константа.НазваниеОрганизации]
    В форме после 09/06/2009
    Она должна иметь свойство "выражение" и ее содержимое - переменная "Продавец", заполненное в зависимости
    от даты документа (см. предыдущее сообщение)
     
  6. yullevick

    yullevick Гость

    Попробую объяснить уровень моего развития как прграмиста.
    На мой вопрос об именении налоговых вычетов я получила такой ответ (который мне полностью понятен: я открыла конфигуратор, в посковик ввела: ТипВычета = Сотрудник.ТипВычета, получила одно совпадение и заменила один обзац другим. Всё отлично работает!!!)
    Открываем конфигуратор
    Документ.НачислениеЗП
    Открываем Модуль документа
    Ищем следующий код:

    Код (Text):
    Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
    Вычеты = 0;
    ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);
    Если ДатаГод(ДатаДок) < 2005 Тогда
    ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
    ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
    ИначеЕсли ДатаГод(ДатаДок) > 2005 Тогда
    ПределВычетов1 = 20000;
    ПределВычетов2 = 40000;
    КонецЕсли;
    Меняем его на такой код:
    Код (Text):
    Если глСотрудникЧислитсяРаботающим(Сотрудник, БухИт.НачДата) = 1 Тогда
    Вычеты = 0;
    ТипВычета = Сотрудник.ТипВычета.Получить(БухИт.КонДата);
    Если ДатаГод(ДатаДок) < 2005 Тогда
    ПределВычетов1 = Константа.ПределВычетов.Получить(БухИт.КонДата);
    ПределВычетов2 = Константа.ПределВычетов.Получить(БухИт.КонДата);
    ИначеЕсли (ДатаГод(ДатаДок) > 2005) И (ДатаГод(ДатаДок) < 2009) Тогда
    ПределВычетов1 = 20000;
    ПределВычетов2 = 40000;
    Иначе
    ПределВычетов1 = 40000;
    ПределВычетов2 = 280000;    
    КонецЕсли;

    В Вашем ответе мне понятно, что нужно добавить, но куда???
    Вам наверное смешно, а мне не до смеха.

    К стати, наверно нужно добавить номер и дату изменения в список в верхнем правом углу сч.-ф.???

    И ещё один вопрос. О плюсиках. Что это такое и икак их добавлять?

    Целую всех!!!
     
  7. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    в процедуре Печать() Документа "СчетФактураВыданный"
    текст
    Если ДатаДок < '09.06.2009' Тогда
    Продавец = СокрЛП(Константа.НазваниеОрганизации);
    Иначе
    Продавец = СокрЛП(Константа.ОфициальноеНазваниеОрганизации) + " (" + СокрЛП(Константа.НазваниеОрганизации) + ")";
    КонецЕсли;

    нужно добавить перед выводом секции "Шапка"
    Зеленая иконка справа от показателя репутации
     
  8. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    yullevick, простите за нескромный вопрос...
    Если вы не программист, почему не хотите пригласить программиста (за деньги), чтобы вам все исправили?
    Скажем, вы бухгалтер... Для вас вполне естественно, что любой сотрудник предприятия может вести бухгалтерский учет просто консультируясь на форумах? Мне крайне интересны ваши мотивы :)
     
  9. yullevick

    yullevick Гость


    В эпоху кризиса я думаю Вы и сами знаете ответ на свой вопрос.
    Лично я с Вами полностью согласна, что каждый должен заниматься своим делом, но, увы, так получается не всегда!
     
  10. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Но деваться-то некуда - простые (как в этом случае) вопросы многие справятся под диктовку и по телефону решить, а если проблема более глобальная ?
     
  11. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    "Разруха. Это - мираж, дым, фикция. Что такое эта ваша разруха? Старуха с клюкой? Ведьма, которая выбила все стекла, потушила все лампы? Да ее вовсе и не существует. Это вот что: если я, вместо того, чтобы оперировать каждый вечер, начну у себя в квартире петь хором, у меня настанет разруха. Если я, входя в уборную, начну, извините за выражение, мочиться мимо унитаза и то же самое будут делать Зина и Дарья Петровна, в уборной начнется разруха. Следовательно, разруха не в клозетах, а в головах. Когда эти баритоны кричат "бей разруху!" - Я смеюсь. Клянусь вам, мне смешно! Это означает, что каждый из них должен лупить себя по затылку! И вот, когда он вылупит из себя всякие галлюцинации и займется чисткой сараев - прямым своим делом, - разруха исчезнет сама собой. Двум богам служить нельзя! Невозможно в одно время подметать трамвайные пути и устраивать судьбы каких-то испанских оборванцев!"
    "Собачье сердце" М.Булгаков
    Думаю, слово "разруха" сами в состоянии заменить на "кризис"?
     
  12. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Заранее извеняюсь за некую глупость (ибо в принцпе kaa все выложил), но хочется уточнить одну деталь:
    обновил релиз, но что-то не вижу чтобы в печатной форме было написано о том что форма "от 26,05,09 №451". у мя одного такой глюк?
     
  13. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    у всех не указано
     
  14. kaa

    kaa Гость

    косяк 1с ников править надо
     
  15. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    править не проблема. было просто удивительно, раньше особо не сталкивался с такими косяками 1Сников
     
  16. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Счастливый ты человек. А то, что нумераторы у них периодически глючат, и об этом всему миру уже лет 10 известно ?
    А сколько релизов бухгалтерии вышло при переходе с НДС20% на 18% ?
    Если мне не изменяет память - десятка полтора за несколько дней
    ...и т.п.
    Вот вставят, наконец, в правый верхний угол данные о постановлении и обзовут это релизом 5.08, а пол-страны будет какое-то время на ушах стоять
     
  17. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    да я с 1Ской не более 2х лет работаю - уже 18% НДСа было... про нумераторы слышал, но лично таки не сталкивался к счастью
     
Загрузка...

Поделиться этой страницей