Как Гиперссылку Сделать Ссылкой На Документ?

hurricane1

New Member
13.01.2011
4
0
#1
Здравствуйте! У меня задача гиперссылкой в ФорматированномДокументе открыть документ информационной базы то есть НавигационнуюСсылку e1cib/data/Документ.ИмяДокумента?ref=82d3001d09bbfde011e3a396ff0bb639. Вот получил я эту навигационную ссылку, присвоил как адрес гиперссылки, но гиперссылка открывает браузер. А нужно чтобы документ! Может какое событие кто знает в котором установить параметр который будет открывать ссылки в ИБ. Или саму ссылку как отформатировать?
 

Дайнеко

Well-Known Member
19.11.2009
951
0
53
Минск
#2
У меня сделано так:
Код:
//----------------------------------------------------------
//	Анализируем если произошло нажание не ссылку
Процедура СодержаниеПредыдущиеonclick(Элемент, pEvtObj)
htmlElement = НайтиСсылку(pEvtObj.srcElement);
Если htmlElement = Неопределено Тогда
Возврат;
КонецЕсли;

// Не отработали нажатие
pEvtObj.returnValue = Ложь;

// Если у ссылки есть идентификатор
СсылкаНаОбъект = htmlElement.id;
Если ЗначениеПустое(htmlElement.id) Тогда
Возврат;
КонецЕсли;

// Получаем адрес ссылки из атрибута id
Документы.Контакт.ПолучитьСсылку(Новый УникальныйИдентификатор(СсылкаНаОбъект)).ПолучитьФорму().Открыть();
КонецПроцедуры

Для Вас пожалуй интересна только последняя строка в процедуре
 

hurricane1

New Member
13.01.2011
4
0
#3
Спасибо за ответ! Честно говоря, для меня ещё интересно где вы нашли это событие СодержаниеПредыдущиеonclick которое ловит нажатие на гиперссылку в ФорматированномДокументе.
 

Дайнеко

Well-Known Member
19.11.2009
951
0
53
Минск
#4
"СодержаниеПредыдущие" - это название моего объекта типа HTML. В режиме только просмотр срабатывает это событие onclick.
С форматированным документом дело не имел. Во-первых, как-то не знал про него.
Во-вторых, когда где-то нарвался на статью про этот объект, не понравилось, что хранить его можно только в Хранилище.