1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Как Гиперссылку Сделать Ссылкой На Документ?

Тема в разделе "Базы данных и администрирование", создана пользователем hurricane1, 5 мар 2014.

  1. hurricane1

    hurricane1 New Member

    Репутация:
    0
    Регистрация:
    13 янв 2011
    Сообщения:
    4
    Симпатии:
    0
    Здравствуйте! У меня задача гиперссылкой в ФорматированномДокументе открыть документ информационной базы то есть НавигационнуюСсылку e1cib/data/Документ.ИмяДокумента?ref=82d3001d09bbfde011e3a396ff0bb639. Вот получил я эту навигационную ссылку, присвоил как адрес гиперссылки, но гиперссылка открывает браузер. А нужно чтобы документ! Может какое событие кто знает в котором установить параметр который будет открывать ссылки в ИБ. Или саму ссылку как отформатировать?
     
  2. Дайнеко

    Дайнеко Well-Known Member

    Репутация:
    0
    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    У меня сделано так:
    Код:
    //----------------------------------------------------------
    //	Анализируем если произошло нажание не ссылку
    Процедура СодержаниеПредыдущиеonclick(Элемент, pEvtObj)
    htmlElement = НайтиСсылку(pEvtObj.srcElement);
    Если htmlElement = Неопределено Тогда
    Возврат;
    КонецЕсли;
    
    // Не отработали нажатие
    pEvtObj.returnValue = Ложь;
    
    // Если у ссылки есть идентификатор
    СсылкаНаОбъект = htmlElement.id;
    Если ЗначениеПустое(htmlElement.id) Тогда
    Возврат;
    КонецЕсли;
    
    // Получаем адрес ссылки из атрибута id
    Документы.Контакт.ПолучитьСсылку(Новый УникальныйИдентификатор(СсылкаНаОбъект)).ПолучитьФорму().Открыть();
    КонецПроцедуры

    Для Вас пожалуй интересна только последняя строка в процедуре
     
  3. hurricane1

    hurricane1 New Member

    Репутация:
    0
    Регистрация:
    13 янв 2011
    Сообщения:
    4
    Симпатии:
    0
    Спасибо за ответ! Честно говоря, для меня ещё интересно где вы нашли это событие СодержаниеПредыдущиеonclick которое ловит нажатие на гиперссылку в ФорматированномДокументе.
     
  4. Дайнеко

    Дайнеко Well-Known Member

    Репутация:
    0
    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    "СодержаниеПредыдущие" - это название моего объекта типа HTML. В режиме только просмотр срабатывает это событие onclick.
    С форматированным документом дело не имел. Во-первых, как-то не знал про него.
    Во-вторых, когда где-то нарвался на статью про этот объект, не понравилось, что хранить его можно только в Хранилище.
     
Загрузка...

Поделиться этой страницей