Как Из Документа-объекта Обратиться К Реквизиту Формы?

Тема в разделе "1C и всё что с ней связано", создана пользователем Надя1972, 1 дек 2014.

  1. Надя1972

    Надя1972 Well-Known Member

    Регистрация:
    23 окт 2013
    Сообщения:
    53
    Симпатии:
    0
    Здравствуйте! Подскажите, пожалуйста, как из документа объекта обратиться к реквизиту формы этого документа? У документа Платежное поручениеИсходящее есть реквизит формы "Список". Мне нужно узнать, истина он, или ложь?
    Код ( (Unknown Language)):
    Док=Документы.ПлатежноеПоручениеИсходящее.Выбрать();
    Пока Док.Следующий() Цикл
    Если Док.?????? Тогда
    КонецЕсли;
    КонецЦикла;
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Что за конфигурация? Если открыть форму в конфигураторе, открыть свойство списка - то что написано в поле имя? Есть ли такой реквизит в документе?
     
  3. Надя1972

    Надя1972 Well-Known Member

    Регистрация:
    23 окт 2013
    Сообщения:
    53
    Симпатии:
    0
     
  4. tanat

    tanat Well-Known Member

    Регистрация:
    2 мар 2007
    Сообщения:
    265
    Симпатии:
    0
    Это влияет только лишь на отображение на форме данных. Сам принцип является неизменным. Обязательным является заполнение табличной части документа платежное поручение. Т.е. если у вас стоит галочка - данные из таблицы заполняют реквизиты на форме, если нет - то отображается сама табличная часть.

    Вам надо обрабатывать количество записей в таблице документа, а не реквизит формы.

    Обратите внимание на Процедуру ПриОткрытии основной формы, там даже есть кусочек кода


    Если РасшифровкаПлатежа.Количество()>1 Тогда
    Список = Истина;
    Иначе
    Список = Ложь;
    КонецЕсли;
     
  5. ЧИА

    ЧИА Active Member

    Регистрация:
    22 окт 2009
    Сообщения:
    33
    Симпатии:
    0
    Если для вас это еще актуально, то приблизительно так:

    Док=Документы.ПлатежноеПоручениеИсходящее.Выбрать();
    Пока Док.Следующий() Цикл
    Форма = Док.ПолучитьФорму();
    СписокИзДокумента = Форма.ЭлементыФормы.Список.Значение;
    // Здесь анализ содержимого реквизита "Список" через переменную СписокИзДокумента
    ....
    КонецЦикла;
     
  6. tanat

    tanat Well-Known Member

    Регистрация:
    2 мар 2007
    Сообщения:
    265
    Симпатии:
    0
    Чойта я могу ошибаться, конечно, однако мне кажется ПолучитьФорму() не запускает обработку ПриОтктытии(). Значит, как мне думается, значение реквизита "Список" будет тем, какое оно стоит по умолчанию.
     
  7. Надя1972

    Надя1972 Well-Known Member

    Регистрация:
    23 окт 2013
    Сообщения:
    53
    Симпатии:
    0
    Спасибо, так примерно и сделала

    Добавлено:
    Спасибо, может пригодится в будующем, пока сделала через анализ количества строк в табличной части
     
Загрузка...

Поделиться этой страницей